public inbox for pve-devel@lists.proxmox.com
 help / color / mirror / Atom feed
From: Fiona Ebner <f.ebner@proxmox.com>
To: "Michael Köppl" <m.koeppl@proxmox.com>, pve-devel@lists.proxmox.com
Subject: Re: [PATCH container v9 05/10] allow pending mount point changes if storage is gone
Date: Wed, 1 Jul 2026 14:22:23 +0200	[thread overview]
Message-ID: <7f0d85c3-3ed2-4266-8410-c067367e359f@proxmox.com> (raw)
In-Reply-To: <DJN86S1O37OM.27Q9EN0ISR3KS@proxmox.com>

Am 01.07.26 um 2:15 PM schrieb Michael Köppl:
> On Tue Jun 30, 2026 at 3:41 PM CEST, Fiona Ebner wrote:
>> I'm thinking about something like
>>
>> with_checked_volid($opt, $conf->{opt}, sub {
>>     my ($volid) = @_;
>>     PVE::LXC::delete_mountpoint_volume($storecfg, $vmid, $volid)
>>         if !$class->is_volume_in_use($conf, $volid, 1, 1);
>> });
>>
>> where the helper does the parsing of the volume and volid, logs the
>> warning and returns if the storage does not exist and calls the
>> passed-in sub if it does exist.
> 
> Sounds good, I'll add a helper. Thanks for the suggestion. Though I'd go
> with something like:
> 
> ```
> sub with_checked_volid {
>     my ($storecfg, $volid, $callback) = @_;
> 
>     my ($storeid) = PVE::Storage::parse_volume_id($volid);
>     if (PVE::Storage::storage_config($storecfg, $storeid, 1)) {
>         callback->();
>     } else {
>         PVE::RESTEnvironment::log_warn(
>             "storage '$storeid' no longer exists, volume '$volid' will be removed");
>     }
> }
> ```
> 
> I'd keep the parsing of the volume outside the helper. The call sites
> don't use the result of parse_volume uniformly. It seems easier to me
> using the same helper across all call sites by passing in an already
> resolved volid as the common denominator. What do you think?

Sound good :)




  reply	other threads:[~2026-07-01 12:22 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-06-29 14:04 [PATCH container/qemu-server/storage v9 00/10] fix #3711 and adapt drive detach/remove behavior Michael Köppl
2026-06-29 14:04 ` [PATCH storage v9 01/10] fix #3711: vdisk_free: print warning if storage does not exist Michael Köppl
2026-06-30 14:21   ` Fiona Ebner
2026-07-01 10:01     ` Michael Köppl
2026-06-29 14:04 ` [PATCH container v9 02/10] fix #3711: warn about storage errors during mountpoint delete Michael Köppl
2026-06-29 14:04 ` [PATCH container v9 03/10] destroy_lxc, delete_mp_volume: rename $volume to $volid Michael Köppl
2026-06-29 14:04 ` [PATCH container v9 04/10] config: ensure valid volid through parse_volume() Michael Köppl
2026-06-29 14:04 ` [PATCH container v9 05/10] allow pending mount point changes if storage is gone Michael Köppl
2026-06-30 13:41   ` Fiona Ebner
2026-07-01 12:15     ` Michael Köppl
2026-07-01 12:22       ` Fiona Ebner [this message]
2026-06-29 14:04 ` [PATCH container v9 06/10] add linked clone check when destroying container template Michael Köppl
2026-06-30 13:57   ` Fiona Ebner
2026-06-29 14:04 ` [PATCH qemu-server v9 07/10] adapt linked clone check to not die if an error occurs during check Michael Köppl
2026-06-30 14:04   ` Fiona Ebner
2026-06-29 14:04 ` [PATCH qemu-server v9 08/10] fix #3711: make removal of VM possible if store does not exist anymore Michael Köppl
2026-06-29 14:04 ` [PATCH qemu-server v9 09/10] destroy_vm: use log_warn for vdisk_free errors for consistency Michael Köppl
2026-06-29 14:04 ` [PATCH qemu-server v9 10/10] display warnings for storage errors or if storage no longer exists Michael Köppl
2026-06-30 14:23 ` [PATCH container/qemu-server/storage v9 00/10] fix #3711 and adapt drive detach/remove behavior Fiona Ebner
2026-07-01 14:14 ` superseded: " Michael Köppl

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=7f0d85c3-3ed2-4266-8410-c067367e359f@proxmox.com \
    --to=f.ebner@proxmox.com \
    --cc=m.koeppl@proxmox.com \
    --cc=pve-devel@lists.proxmox.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Service provided by Proxmox Server Solutions GmbH | Privacy | Legal