public inbox for pve-devel@lists.proxmox.com
 help / color / mirror / Atom feed
From: Fiona Ebner <f.ebner@proxmox.com>
To: "Michael Köppl" <m.koeppl@proxmox.com>, pve-devel@lists.proxmox.com
Subject: Re: [PATCH container v9 05/10] allow pending mount point changes if storage is gone
Date: Tue, 30 Jun 2026 15:41:16 +0200	[thread overview]
Message-ID: <576f756c-9c81-4058-9b41-ed81a1a66a07@proxmox.com> (raw)
In-Reply-To: <20260629140439.184878-6-m.koeppl@proxmox.com>

Am 29.06.26 um 4:06 PM schrieb Michael Köppl:
> Previously, applying a pending removal of an unused volume whose
> backing storage was already removed would fail with "unable to apply
> pending change unusedN", leaving a dangling reference that could never
> be cleaned up.
> 
> Guard the volume deletion in vmconfig_apply_pending and
> vmconfig_hotplug_pending with a check to ensure that the storage
> exists. If the storage is gone, drop the entry with a warning instead of
> trying to free a volume that no longer exists.
> 
> Apply the same check when a detached mount point is turned into an
> 'unusedN' entry, so a volume on a removed storage is not re-added as a
> dangling unused entry, matching VM behavior.
> 
> Signed-off-by: Michael Köppl <m.koeppl@proxmox.com>
> ---
>  src/PVE/LXC/Config.pm | 43 ++++++++++++++++++++++++++++++++++---------
>  1 file changed, 34 insertions(+), 9 deletions(-)
> 
> diff --git a/src/PVE/LXC/Config.pm b/src/PVE/LXC/Config.pm
> index c8098538..a3dd3a1a 100644
> --- a/src/PVE/LXC/Config.pm
> +++ b/src/PVE/LXC/Config.pm

Missing import for PVE::RESTEnvironment.

> @@ -1663,8 +1663,14 @@ sub vmconfig_hotplug_pending {
>                  # pass
>              } elsif ($opt =~ m/^unused(\d+)$/) {
>                  my $volid = $class->parse_volume($opt, $conf->{$opt})->{volume};
> -                PVE::LXC::delete_mountpoint_volume($storecfg, $vmid, $volid)
> -                    if !$class->is_volume_in_use($conf, $volid, 1, 1);
> +                my ($storeid) = PVE::Storage::parse_volume_id($volid);
> +                if (PVE::Storage::storage_config($storecfg, $storeid, 1)) {
> +                    PVE::LXC::delete_mountpoint_volume($storecfg, $vmid, $volid)
> +                        if !$class->is_volume_in_use($conf, $volid, 1, 1);
> +                } else {
> +                    PVE::RESTEnvironment::log_warn(
> +                        "storage '$storeid' no longer exists, unused volume '$volid' will be removed");
> +                }

Style nit: should we add a helper for readability/to reduce bloat and
repetition?

I'm thinking about something like

with_checked_volid($opt, $conf->{opt}, sub {
    my ($volid) = @_;
    PVE::LXC::delete_mountpoint_volume($storecfg, $vmid, $volid)
        if !$class->is_volume_in_use($conf, $volid, 1, 1);
});

where the helper does the parsing of the volume and volid, logs the
warning and returns if the storage does not exist and calls the
passed-in sub if it does exist.




  reply	other threads:[~2026-06-30 13:41 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-06-29 14:04 [PATCH container/qemu-server/storage v9 00/10] fix #3711 and adapt drive detach/remove behavior Michael Köppl
2026-06-29 14:04 ` [PATCH storage v9 01/10] fix #3711: vdisk_free: print warning if storage does not exist Michael Köppl
2026-06-30 14:21   ` Fiona Ebner
2026-07-01 10:01     ` Michael Köppl
2026-06-29 14:04 ` [PATCH container v9 02/10] fix #3711: warn about storage errors during mountpoint delete Michael Köppl
2026-06-29 14:04 ` [PATCH container v9 03/10] destroy_lxc, delete_mp_volume: rename $volume to $volid Michael Köppl
2026-06-29 14:04 ` [PATCH container v9 04/10] config: ensure valid volid through parse_volume() Michael Köppl
2026-06-29 14:04 ` [PATCH container v9 05/10] allow pending mount point changes if storage is gone Michael Köppl
2026-06-30 13:41   ` Fiona Ebner [this message]
2026-07-01 12:15     ` Michael Köppl
2026-07-01 12:22       ` Fiona Ebner
2026-06-29 14:04 ` [PATCH container v9 06/10] add linked clone check when destroying container template Michael Köppl
2026-06-30 13:57   ` Fiona Ebner
2026-06-29 14:04 ` [PATCH qemu-server v9 07/10] adapt linked clone check to not die if an error occurs during check Michael Köppl
2026-06-30 14:04   ` Fiona Ebner
2026-06-29 14:04 ` [PATCH qemu-server v9 08/10] fix #3711: make removal of VM possible if store does not exist anymore Michael Köppl
2026-06-29 14:04 ` [PATCH qemu-server v9 09/10] destroy_vm: use log_warn for vdisk_free errors for consistency Michael Köppl
2026-06-29 14:04 ` [PATCH qemu-server v9 10/10] display warnings for storage errors or if storage no longer exists Michael Köppl
2026-06-30 14:23 ` [PATCH container/qemu-server/storage v9 00/10] fix #3711 and adapt drive detach/remove behavior Fiona Ebner
2026-07-01 14:14 ` superseded: " Michael Köppl

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=576f756c-9c81-4058-9b41-ed81a1a66a07@proxmox.com \
    --to=f.ebner@proxmox.com \
    --cc=m.koeppl@proxmox.com \
    --cc=pve-devel@lists.proxmox.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Service provided by Proxmox Server Solutions GmbH | Privacy | Legal