From: "Michael Köppl" <m.koeppl@proxmox.com>
To: pve-devel@lists.proxmox.com
Subject: [PATCH container v10 04/10] lxc config: add helper for parsing volid and checking if storage exists
Date: Wed, 1 Jul 2026 16:13:33 +0200 [thread overview]
Message-ID: <20260701141339.181276-5-m.koeppl@proxmox.com> (raw)
In-Reply-To: <20260701141339.181276-1-m.koeppl@proxmox.com>
Add a helper function to avoid repetition across multiple call sites
where a volume id is parsed and functions check for the existence of the
given storage, log a warning and return if it does not exist, and
perform some action otherwise (e.g. adding a disk as unused).
Signed-off-by: Michael Köppl <m.koeppl@proxmox.com>
---
src/PVE/LXC/Config.pm | 15 +++++++++++++++
1 file changed, 15 insertions(+)
diff --git a/src/PVE/LXC/Config.pm b/src/PVE/LXC/Config.pm
index c8098538..57c93e8a 100644
--- a/src/PVE/LXC/Config.pm
+++ b/src/PVE/LXC/Config.pm
@@ -11,6 +11,7 @@ use PVE::DataCenterConfig;
use PVE::GuestHelpers;
use PVE::INotify;
use PVE::JSONSchema qw(get_standard_option);
+use PVE::RESTEnvironment;
use PVE::Tools;
use PVE::LXC;
@@ -1609,6 +1610,20 @@ sub calculate_memory_constraints {
return ($memory_max, $memory_high);
}
+# Skip and warn if a volume's backing storage was already removed from the storage config, so
+# guest/volume removal can still proceed.
+sub with_checked_volid {
+ my ($storecfg, $volid, $callback) = @_;
+
+ my ($storeid) = PVE::Storage::parse_volume_id($volid);
+ if (PVE::Storage::storage_config($storecfg, $storeid, 1)) {
+ $callback->();
+ } else {
+ PVE::RESTEnvironment::log_warn(
+ "storage '$storeid' no longer exists, volume '$volid' will be removed");
+ }
+}
+
my $LXC_FASTPLUG_OPTIONS = {
'description' => 1,
'onboot' => 1,
--
2.47.3
next prev parent reply other threads:[~2026-07-01 14:13 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-01 14:13 [PATCH container/qemu-server v10 00/10] fix #3711 and adapt drive detach/remove behavior Michael Köppl
2026-07-01 14:13 ` [PATCH container v10 01/10] fix #3711: warn about storage errors during mountpoint delete Michael Köppl
2026-07-01 14:13 ` [PATCH container v10 02/10] destroy_lxc, delete_mp_volume: rename $volume to $volid Michael Köppl
2026-07-01 14:13 ` [PATCH container v10 03/10] config: ensure valid volid through parse_volume() Michael Köppl
2026-07-01 14:13 ` Michael Köppl [this message]
2026-07-01 14:13 ` [PATCH container v10 05/10] allow pending mount point changes if storage is gone Michael Köppl
2026-07-01 14:13 ` [PATCH container v10 06/10] destroy template: add early check for linked clones of volumes Michael Köppl
2026-07-01 14:13 ` [PATCH qemu-server v10 07/10] adapt linked clone check to not die if an error occurs during check Michael Köppl
2026-07-01 14:13 ` [PATCH qemu-server v10 08/10] fix #3711: make removal of VM possible if store does not exist anymore Michael Köppl
2026-07-01 14:13 ` [PATCH qemu-server v10 09/10] destroy_vm: use log_warn for vdisk_free errors for consistency Michael Köppl
2026-07-01 14:13 ` [PATCH qemu-server v10 10/10] display warnings for storage errors or if storage no longer exists Michael Köppl
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260701141339.181276-5-m.koeppl@proxmox.com \
--to=m.koeppl@proxmox.com \
--cc=pve-devel@lists.proxmox.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox