all lists on lists.proxmox.com
 help / color / mirror / Atom feed
* [PATCH manager] fix #6211: ui: vm: options: add tooltip to protection option
@ 2026-07-13 11:46 Elias Huhsovitz
  2026-07-15 12:17 ` Dominik Csapak
  0 siblings, 1 reply; 4+ messages in thread
From: Elias Huhsovitz @ 2026-07-13 11:46 UTC (permalink / raw)
  To: pve-devel; +Cc: Elias Huhsovitz

The "protection" options was ambiguous.
Add tooltip to briefly describe the option.

Signed-off-by: Elias Huhsovitz <e.huhsovitz@proxmox.com>
---
 www/manager6/qemu/Options.js | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/www/manager6/qemu/Options.js b/www/manager6/qemu/Options.js
index 8a4721a0..9ade5ccb 100644
--- a/www/manager6/qemu/Options.js
+++ b/www/manager6/qemu/Options.js
@@ -326,6 +326,10 @@ Ext.define('PVE.qemu.Options', {
                               defaultValue: 0,
                               deleteDefaultValue: true,
                               fieldLabel: gettext('Enabled'),
+                              afterLabelTextTpl: ' <i class="fa fa-question-circle" style="color: #888; cursor: help; margin-left: 4px;"></i>',
+                              autoEl: {
+                                  'data-qtip': gettext('Prevents the VM and its disks from being removed')
+                              }
                           },
                       }
                     : undefined,
-- 
2.47.3





^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH manager] fix #6211: ui: vm: options: add tooltip to protection option
  2026-07-13 11:46 [PATCH manager] fix #6211: ui: vm: options: add tooltip to protection option Elias Huhsovitz
@ 2026-07-15 12:17 ` Dominik Csapak
  2026-07-16  8:09   ` Elias Huhsovitz
  0 siblings, 1 reply; 4+ messages in thread
From: Dominik Csapak @ 2026-07-15 12:17 UTC (permalink / raw)
  To: Elias Huhsovitz, pve-devel

would speak anything against putting the icon into the 'boxLabel'
instead of to the fieldlabel?

that would put it right next to the actual checkbox and not
to the relatively generic 'enabled' label
i think our users should now what 'enabled' means, but
what we want to convey is the meaning of the actual option

On 7/13/26 1:47 PM, Elias Huhsovitz wrote:
> The "protection" options was ambiguous.
> Add tooltip to briefly describe the option.
> 
> Signed-off-by: Elias Huhsovitz <e.huhsovitz@proxmox.com>
> ---
>   www/manager6/qemu/Options.js | 4 ++++
>   1 file changed, 4 insertions(+)
> 
> diff --git a/www/manager6/qemu/Options.js b/www/manager6/qemu/Options.js
> index 8a4721a0..9ade5ccb 100644
> --- a/www/manager6/qemu/Options.js
> +++ b/www/manager6/qemu/Options.js
> @@ -326,6 +326,10 @@ Ext.define('PVE.qemu.Options', {
>                                 defaultValue: 0,
>                                 deleteDefaultValue: true,
>                                 fieldLabel: gettext('Enabled'),
> +                              afterLabelTextTpl: ' <i class="fa fa-question-circle" style="color: #888; cursor: help; margin-left: 4px;"></i>',
> +                              autoEl: {
> +                                  'data-qtip': gettext('Prevents the VM and its disks from being removed')
> +                              }
>                             },
>                         }
>                       : undefined,





^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH manager] fix #6211: ui: vm: options: add tooltip to protection option
  2026-07-15 12:17 ` Dominik Csapak
@ 2026-07-16  8:09   ` Elias Huhsovitz
  2026-07-16  9:29     ` Dominik Csapak
  0 siblings, 1 reply; 4+ messages in thread
From: Elias Huhsovitz @ 2026-07-16  8:09 UTC (permalink / raw)
  To: Dominik Csapak, pve-devel

I tried moving the icon to the `boxLabel` as suggested, but in my opinion, it looks a bit off.

Instead of adding a tooltip to clarify the ambiguous "Protection" label, I propose an alternative design decision.
We could rename the option entirely to "Disable VM and Disk removal".
This would make the option self-explanatory and allow us to omit the tooltip altogether.

Let me know your thoughts on this approach. 

On Wed Jul 15, 2026 at 2:17 PM CEST, Dominik Csapak wrote:
> would speak anything against putting the icon into the 'boxLabel'
> instead of to the fieldlabel?
>
> that would put it right next to the actual checkbox and not
> to the relatively generic 'enabled' label
> i think our users should now what 'enabled' means, but
> what we want to convey is the meaning of the actual option
>
> On 7/13/26 1:47 PM, Elias Huhsovitz wrote:
>> The "protection" options was ambiguous.
>> Add tooltip to briefly describe the option.
>> 
>> Signed-off-by: Elias Huhsovitz <e.huhsovitz@proxmox.com>
>> ---
>>   www/manager6/qemu/Options.js | 4 ++++
>>   1 file changed, 4 insertions(+)
>> 
>> diff --git a/www/manager6/qemu/Options.js b/www/manager6/qemu/Options.js
>> index 8a4721a0..9ade5ccb 100644
>> --- a/www/manager6/qemu/Options.js
>> +++ b/www/manager6/qemu/Options.js
>> @@ -326,6 +326,10 @@ Ext.define('PVE.qemu.Options', {
>>                                 defaultValue: 0,
>>                                 deleteDefaultValue: true,
>>                                 fieldLabel: gettext('Enabled'),
>> +                              afterLabelTextTpl: ' <i class="fa fa-question-circle" style="color: #888; cursor: help; margin-left: 4px;"></i>',
>> +                              autoEl: {
>> +                                  'data-qtip': gettext('Prevents the VM and its disks from being removed')
>> +                              }
>>                             },
>>                         }
>>                       : undefined,





^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH manager] fix #6211: ui: vm: options: add tooltip to protection option
  2026-07-16  8:09   ` Elias Huhsovitz
@ 2026-07-16  9:29     ` Dominik Csapak
  0 siblings, 0 replies; 4+ messages in thread
From: Dominik Csapak @ 2026-07-16  9:29 UTC (permalink / raw)
  To: Elias Huhsovitz, pve-devel



On 7/16/26 10:09 AM, Elias Huhsovitz wrote:
> I tried moving the icon to the `boxLabel` as suggested, but in my opinion, it looks a bit off.
> 
> Instead of adding a tooltip to clarify the ambiguous "Protection" label, I propose an alternative design decision.
> We could rename the option entirely to "Disable VM and Disk removal".
> This would make the option self-explanatory and allow us to omit the tooltip altogether.

mhmm I'm a bit torn about this. on one hand i think that would clear
things up a bit and avoid the necessity for a tooltip/info,
but on the other hand, it'll confuse long term users
that'll search for the 'protection' option and if we
will use it for anything else, the text is wrong/outdated.

what about my initial suggestion to just having the text in the boxlabel?
or we go back to the initial proposal of adding a separate hint field

> 
> Let me know your thoughts on this approach.
> 
> On Wed Jul 15, 2026 at 2:17 PM CEST, Dominik Csapak wrote:
>> would speak anything against putting the icon into the 'boxLabel'
>> instead of to the fieldlabel?
>>
>> that would put it right next to the actual checkbox and not
>> to the relatively generic 'enabled' label
>> i think our users should now what 'enabled' means, but
>> what we want to convey is the meaning of the actual option
>>
>> On 7/13/26 1:47 PM, Elias Huhsovitz wrote:
>>> The "protection" options was ambiguous.
>>> Add tooltip to briefly describe the option.
>>>
>>> Signed-off-by: Elias Huhsovitz <e.huhsovitz@proxmox.com>
>>> ---
>>>    www/manager6/qemu/Options.js | 4 ++++
>>>    1 file changed, 4 insertions(+)
>>>
>>> diff --git a/www/manager6/qemu/Options.js b/www/manager6/qemu/Options.js
>>> index 8a4721a0..9ade5ccb 100644
>>> --- a/www/manager6/qemu/Options.js
>>> +++ b/www/manager6/qemu/Options.js
>>> @@ -326,6 +326,10 @@ Ext.define('PVE.qemu.Options', {
>>>                                  defaultValue: 0,
>>>                                  deleteDefaultValue: true,
>>>                                  fieldLabel: gettext('Enabled'),
>>> +                              afterLabelTextTpl: ' <i class="fa fa-question-circle" style="color: #888; cursor: help; margin-left: 4px;"></i>',
>>> +                              autoEl: {
>>> +                                  'data-qtip': gettext('Prevents the VM and its disks from being removed')
>>> +                              }
>>>                              },
>>>                          }
>>>                        : undefined,
> 





^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2026-07-16  9:30 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-07-13 11:46 [PATCH manager] fix #6211: ui: vm: options: add tooltip to protection option Elias Huhsovitz
2026-07-15 12:17 ` Dominik Csapak
2026-07-16  8:09   ` Elias Huhsovitz
2026-07-16  9:29     ` Dominik Csapak

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.
Service provided by Proxmox Server Solutions GmbH | Privacy | Legal