From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from gate001.proxmox.com (gate001.proxmox.com [45.144.208.40]) by lore.proxmox.com (Postfix) with ESMTPS id C923F1FF0E9 for ; Thu, 16 Jul 2026 10:09:28 +0200 (CEST) Received: from gate001.proxmox.com (localhost.localdomain [127.0.0.1]) by gate001.proxmox.com (Proxmox) with ESMTP id 3D20E21419; Thu, 16 Jul 2026 10:09:28 +0200 (CEST) Mime-Version: 1.0 Content-Transfer-Encoding: quoted-printable Content-Type: text/plain; charset=UTF-8 Date: Thu, 16 Jul 2026 10:09:23 +0200 Message-Id: To: "Dominik Csapak" , Subject: Re: [PATCH manager] fix #6211: ui: vm: options: add tooltip to protection option From: "Elias Huhsovitz" X-Mailer: aerc 0.20.0 References: <20260713114657.147881-1-e.huhsovitz@proxmox.com> <97c1aba3-6dda-4ac0-8935-f0009e453c3a@proxmox.com> In-Reply-To: <97c1aba3-6dda-4ac0-8935-f0009e453c3a@proxmox.com> X-Bm-Milter-Handled: 55990f41-d878-4baa-be0a-ee34c49e34d2 X-Bm-Transport-Timestamp: 1784189344373 X-SPAM-LEVEL: Spam detection results: 0 AWL 0.270 Adjusted score from AWL reputation of From: address DMARC_MISSING 0.1 Missing DMARC policy KAM_DMARC_STATUS 0.01 Test Rule for DKIM or SPF Failure with Strict Alignment (newer systems) RCVD_IN_DNSWL_LOW -0.7 Sender listed at https://www.dnswl.org/, low trust SPF_HELO_NONE 0.001 SPF: HELO does not publish an SPF Record SPF_PASS -0.001 SPF: sender matches SPF record Message-ID-Hash: MBIJUSA3BEHRCQ7762E6BNCMEZ6XJMWC X-Message-ID-Hash: MBIJUSA3BEHRCQ7762E6BNCMEZ6XJMWC X-MailFrom: e.huhsovitz@proxmox.com X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header X-Mailman-Version: 3.3.10 Precedence: list List-Id: Proxmox VE development discussion List-Help: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: I tried moving the icon to the `boxLabel` as suggested, but in my opinion, = it looks a bit off. Instead of adding a tooltip to clarify the ambiguous "Protection" label, I = propose an alternative design decision. We could rename the option entirely to "Disable VM and Disk removal". This would make the option self-explanatory and allow us to omit the toolti= p altogether. Let me know your thoughts on this approach.=20 On Wed Jul 15, 2026 at 2:17 PM CEST, Dominik Csapak wrote: > would speak anything against putting the icon into the 'boxLabel' > instead of to the fieldlabel? > > that would put it right next to the actual checkbox and not > to the relatively generic 'enabled' label > i think our users should now what 'enabled' means, but > what we want to convey is the meaning of the actual option > > On 7/13/26 1:47 PM, Elias Huhsovitz wrote: >> The "protection" options was ambiguous. >> Add tooltip to briefly describe the option. >>=20 >> Signed-off-by: Elias Huhsovitz >> --- >> www/manager6/qemu/Options.js | 4 ++++ >> 1 file changed, 4 insertions(+) >>=20 >> diff --git a/www/manager6/qemu/Options.js b/www/manager6/qemu/Options.js >> index 8a4721a0..9ade5ccb 100644 >> --- a/www/manager6/qemu/Options.js >> +++ b/www/manager6/qemu/Options.js >> @@ -326,6 +326,10 @@ Ext.define('PVE.qemu.Options', { >> defaultValue: 0, >> deleteDefaultValue: true, >> fieldLabel: gettext('Enabled'), >> + afterLabelTextTpl: ' '= , >> + autoEl: { >> + 'data-qtip': gettext('Prevents the VM= and its disks from being removed') >> + } >> }, >> } >> : undefined,