public inbox for pve-devel@lists.proxmox.com
 help / color / mirror / Atom feed
From: Gabriel Goller <g.goller@proxmox.com>
To: Christoph Heiss <c.heiss@proxmox.com>
Cc: Proxmox VE development discussion <pve-devel@lists.proxmox.com>
Subject: Re: [pve-devel] [PATCH pve-manager 5/7] fabrics: add NodeEdit components
Date: Fri, 4 Apr 2025 17:45:35 +0200	[thread overview]
Message-ID: <t4keh3httllbyvgtolbiwqvxwkhjo5htuixhfrs4lsqlrxrc67@exow74p4qhir> (raw)
In-Reply-To: <D8WW2HAVN0E1.1SEMKA8CUSXRQ@proxmox.com>

On 03.04.2025 11:16, Christoph Heiss wrote:
>On Fri Mar 28, 2025 at 6:13 PM CET, Gabriel Goller wrote:
>[..]
>> diff --git a/www/manager6/sdn/fabrics/openfabric/NodeEdit.js b/www/manager6/sdn/fabrics/openfabric/NodeEdit.js
>> new file mode 100644
>> index 000000000000..f2d204c22542
>> --- /dev/null
>> +++ b/www/manager6/sdn/fabrics/openfabric/NodeEdit.js
>> @@ -0,0 +1,205 @@
>> +Ext.define('PVE.sdn.Fabric.OpenFabric.Node.InputPanel', {
>> +    extend: 'Proxmox.panel.InputPanel',
>> +
>> +    viewModel: {},
>> +
>> +    isCreate: undefined,
>> +    loadClusterInterfaces: undefined,
>> +
>> +    interface_selector: undefined,
>> +    node_not_accessible_warning: undefined,
>
>All new variables should be camelCase [0] here too, as noted in a later
>patch.
>
>[0] https://pve.proxmox.com/wiki/Javascript_Style_Guide#Casing

Done, I hope I didn't miss anything.

>> +
>[..]
>> +    initComponent: function() {
>> +	let me = this;
>> +	me.interface_selector = Ext.create('PVE.sdn.Fabric.OpenFabric.InterfacePanel', {
>> +	    name: 'interfaces',
>> +	    parentClass: me.isCreate ? me : undefined,
>> +	});
>> +	me.items = [
>> +	    {
>> +		xtype: 'pveNodeSelector',
>> +		reference: 'nodeselector',
>> +		fieldLabel: gettext('Node'),
>> +		labelWidth: 120,
>> +		name: 'node',
>> +		allowBlank: false,
>> +		disabled: !me.isCreate,
>> +		onlineValidator: me.isCreate,
>> +		autoSelect: me.isCreate,
>> +		listeners: {
>> +		    change: function(f, value) {
>> +			if (me.isCreate) {
>> +			    me.loadClusterInterfaces(value, (result) => {
>> +				me.setValues({ network_interfaces: result });
>> +			    });
>> +			}
>> +		    },
>> +		},
>> +		listConfig: {
>> +		    columns: [
>> +			{
>> +			    header: gettext('Node'),
>> +			    dataIndex: 'node',
>> +			    sortable: true,
>> +			    hideable: false,
>> +			    flex: 1,
>> +			},
>> +		    ],
>> +		},
>
>For the node selector, it would be great if existing nodes could be
>excluded from the dropdown. It isn't possible anyway and throws an error
>on submit, so excluding them here would be good UX.
>
>The `allowedNodes` and/or `disallowedNodes` properties on the
>selector can be used for this.

Yep, implemented this.

>
>> +
>> +	    },
>> +	    me.node_not_accessible_warning,
>> +	    {
>> +		xtype: 'textfield',
>> +		fieldLabel: gettext('Loopback IP'),
>> +		labelWidth: 120,
>> +		name: 'router_id',
>> +		allowBlank: false,
>> +	    },
>
>Here, the user-visible name is 'Loopback IP', internally it is named
>'Router ID'. In the documentation, 'Router-ID' is used too in the
>associated documentation.
>
>Perhaps just settle on Router-ID? As long as it is explained in the
>documentation (maybe also add a tooltip?), I wouldn't use a separate
>name IMHO.

We chose 'Loopback IP' as the user-facing term. Internally it's still
router-id.

>
>> +	    me.interface_selector,
>> +	];
>> +	me.callParent();
>> +    },
>> +});
>> +
>> +Ext.define('PVE.sdn.Fabric.OpenFabric.Node.Edit', {
>> +    extend: 'Proxmox.window.Edit',
>> +    xtype: 'pveSDNFabricAddNode',
>[..]
>> +
>> +    initComponent: function() {
>> +	let me = this;
>> +
>> +	me.node_not_accessible_warning = Ext.create('Proxmox.form.field.DisplayEdit', {
>> +	    userCls: 'pmx-hint',
>> +	    value: gettext('The node is not accessible.'),
>> +	    hidden: true,
>> +	});
>> +
>> +	let ipanel = Ext.create('PVE.sdn.Fabric.OpenFabric.Node.InputPanel', {
>> +	    node_not_accessible_warning: me.node_not_accessible_warning,
>> +	    isCreate: me.isCreate,
>> +	    loadClusterInterfaces: me.loadClusterInterfaces,
>> +	});
>> +
>> +	Ext.apply(me, {
>> +	    subject: gettext('Node'),
>
>Can be moved to a direct member assignment outside of initComponent().

Done.

>> +	    items: [ipanel],
>> +	});
>> +
>> +	me.callParent();
>> +
>> +	if (!me.isCreate) {
>> +	    me.loadAllAvailableNodes((allNodes) => {
>> +		if (allNodes.some(i => i.name === me.node)) {
>> +		    me.loadClusterInterfaces(me.node, (clusterResult) => {
>> +			me.loadFabricInterfaces(me.fabric, me.node, (fabricResult) => {
>> +			    fabricResult.interface = fabricResult.interface
>> +				.map(i => PVE.Parser.parsePropertyString(i));
>> +
>> +			    let data = {
>> +				node: fabricResult,
>> +				network_interfaces: clusterResult,
>> +			    };
>> +
>> +			    ipanel.setValues(data);
>> +			});
>> +		    });
>
>nit: perhaps move some of this into functions? This is pretty deeply
>nested at this point. Would make it definitely more readable.

Hmm debatable I guess—I find this quite ok readable, you get a sense of
what gets done after what.

Even if we split this up in function, the control flow will be harder to
see IMO.

>> +		} else {
>> +		    me.node_not_accessible_warning.setHidden(false);
>> +		    // If the node is not currently in the cluster and not available (we can't get it's interfaces).
>> +		    me.loadFabricInterfaces(me.fabric, me.node, (fabricResult) => {
>> +			fabricResult.interface = fabricResult.interface
>> +			    .map(i => PVE.Parser.parsePropertyString(i));
>> +
>> +			let data = {
>> +			    node: fabricResult,
>> +			};
>> +
>> +			ipanel.setValues(data);
>> +		    });
>> +		}
>> +	    });
>
>Seems oddly similar to the above, could this be simplified/abstracted a
>bit over both? If its feasible, of course.

I think that will make it more complicated, this clearly separates the
"connected" and the "unconnected" node.

>> +	}
>> +
>> +	if (me.isCreate) {
>> +	    me.method = 'POST';
>> +	} else {
>> +	    me.method = 'PUT';
>> +	}
>> +    },
>> +});
>> +
>> diff --git a/www/manager6/sdn/fabrics/ospf/NodeEdit.js b/www/manager6/sdn/fabrics/ospf/NodeEdit.js
>> new file mode 100644
>> index 000000000000..d022272b5428
>> --- /dev/null
>> +++ b/www/manager6/sdn/fabrics/ospf/NodeEdit.js
>> @@ -0,0 +1,207 @@
>> +Ext.define('PVE.sdn.Fabric.Ospf.Node.InputPanel', {
>> +    extend: 'Proxmox.panel.InputPanel',
>[..]
>> +
>> +Ext.define('PVE.sdn.Fabric.Ospf.Node.Edit', {
>
>Overall, seems this component is mostly the same as the respective
>OpenFabric counterpart - maybe a common parent ExtJS component can be
>created?

Yep, factored out the NodeEdit and FabricEdit for OpenFabric and OSPF so
we have to common components.

>[..]
>> +
>> +    initComponent: function() {
>> +	let me = this;
>> +
>> +	me.node_not_accessible_warning = Ext.create('Proxmox.form.field.DisplayEdit', {
>> +	    userCls: 'pmx-hint',
>> +	    value: gettext('The node is not accessible.'),
>> +	    hidden: true,
>> +	});
>> +
>> +
>> +	let ipanel = Ext.create('PVE.sdn.Fabric.Ospf.Node.InputPanel', {
>> +	    interface_selector: me.interface_selector,
>> +	    node_not_accessible_warning: me.node_not_accessible_warning,
>> +	    isCreate: me.isCreate,
>> +	    loadClusterInterfaces: me.loadClusterInterfaces,
>> +	});
>> +
>> +	Ext.apply(me, {
>> +	    subject: gettext('Node'),
>> +	    items: [ipanel],
>> +	});
>> +
>> +	me.callParent();
>> +
>> +	if (!me.isCreate) {
>> +	    me.loadAllAvailableNodes((allNodes) => {
>> +		if (allNodes.some(i => i.name === me.node)) {
>> +		    me.loadClusterInterfaces(me.node, (clusterResult) => {
>> +			me.loadFabricInterfaces(me.fabric, me.node, (fabricResult) => {
>> +			    fabricResult.interface = fabricResult.interface
>> +				.map(i => PVE.Parser.parsePropertyString(i));
>> +
>> +			    let data = {
>> +				node: fabricResult,
>> +				network_interfaces: clusterResult,
>> +			    };
>> +
>> +			    ipanel.setValues(data);
>> +			});
>> +		    });
>> +		} else {
>> +		    me.node_not_accessible_warning.setHidden(false);
>> +		    // If the node is not currently in the cluster and not available (we can't get it's interfaces).
>> +			me.loadFabricInterfaces(me.fabric, me.node, (fabricResult) => {
>
>nit: wrong indentation :^)

Fixed :)

Thanks for the review!


_______________________________________________
pve-devel mailing list
pve-devel@lists.proxmox.com
https://lists.proxmox.com/cgi-bin/mailman/listinfo/pve-devel

  reply	other threads:[~2025-04-04 15:46 UTC|newest]

Thread overview: 96+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-03-28 17:12 [pve-devel] [PATCH cluster/docs/manager/network/proxmox{, -ve-rs, -firewall, -perl-rs} 00/52] Add SDN Fabrics Gabriel Goller
2025-03-28 17:12 ` [pve-devel] [PATCH proxmox 1/1] serde: add string_as_bool module for boolean string parsing Gabriel Goller
2025-03-28 17:12 ` [pve-devel] [PATCH proxmox-ve-rs 01/17] add proxmox-network-types crate Gabriel Goller
2025-03-31 14:09   ` Thomas Lamprecht
2025-03-31 14:38     ` Stefan Hanreich
2025-03-31 16:20       ` Thomas Lamprecht
2025-03-28 17:12 ` [pve-devel] [PATCH proxmox-ve-rs 02/17] network-types: add common hostname and openfabric types Gabriel Goller
2025-03-28 17:12 ` [pve-devel] [PATCH proxmox-ve-rs 03/17] network-types: add openfabric NET type Gabriel Goller
2025-03-28 17:12 ` [pve-devel] [PATCH proxmox-ve-rs 04/17] network-types: move Ipv4Cidr and Ipv6Cidr types Gabriel Goller
2025-03-28 17:12 ` [pve-devel] [PATCH proxmox-ve-rs 05/17] frr: create proxmox-frr crate Gabriel Goller
2025-03-28 17:12 ` [pve-devel] [PATCH proxmox-ve-rs 06/17] frr: add common frr types Gabriel Goller
2025-03-28 17:12 ` [pve-devel] [PATCH proxmox-ve-rs 07/17] frr: add openfabric types Gabriel Goller
2025-03-28 17:12 ` [pve-devel] [PATCH proxmox-ve-rs 08/17] frr: add ospf types Gabriel Goller
2025-03-28 17:12 ` [pve-devel] [PATCH proxmox-ve-rs 09/17] frr: add route-map types Gabriel Goller
2025-03-28 17:12 ` [pve-devel] [PATCH proxmox-ve-rs 10/17] frr: add generic types over openfabric and ospf Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH proxmox-ve-rs 11/17] frr: add serializer for all FRR types Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH proxmox-ve-rs 12/17] ve-config: add openfabric section-config Gabriel Goller
2025-03-31 13:48   ` Christoph Heiss
2025-03-31 15:04     ` Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH proxmox-ve-rs 13/17] ve-config: add ospf section-config Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH proxmox-ve-rs 14/17] ve-config: add FRR conversion helpers for openfabric and ospf Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH proxmox-ve-rs 15/17] ve-config: add validation for section-config Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH proxmox-ve-rs 16/17] ve-config: add section-config to frr types conversion Gabriel Goller
2025-03-31 13:51   ` Christoph Heiss
2025-03-31 14:31     ` Stefan Hanreich
2025-03-28 17:13 ` [pve-devel] [PATCH proxmox-ve-rs 17/17] ve-config: add integrations tests Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH proxmox-firewall 1/1] firewall: nftables: migrate to proxmox-network-types Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH proxmox-perl-rs 1/7] perl-rs: sdn: initial fabric infrastructure Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH proxmox-perl-rs 2/7] perl-rs: sdn: add CRUD helpers for OpenFabric fabric management Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH proxmox-perl-rs 3/7] perl-rs: sdn: OpenFabric perlmod methods Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH proxmox-perl-rs 4/7] perl-rs: sdn: implement OSPF interface file configuration generation Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH proxmox-perl-rs 5/7] perl-rs: sdn: add CRUD helpers for OSPF fabric management Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH proxmox-perl-rs 6/7] perl-rs: sdn: OSPF perlmod methods Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH proxmox-perl-rs 7/7] perl-rs: sdn: implement OSPF interface file configuration generation Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-cluster 1/1] cluster: add sdn fabrics config files Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 01/17] sdn: fix value returned by pending_config Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 02/17] debian: add dependency to proxmox-perl-rs Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 03/17] fabrics: add fabrics module Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 04/17] refactor: controller: move frr methods into helper Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 05/17] controllers: implement new api for frr config generation Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 06/17] sdn: add frr config generation helper Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 07/17] test: isis: add test for standalone configuration Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 08/17] sdn: frr: add daemon status to frr helper Gabriel Goller
2025-04-02 10:41   ` Fabian Grünbichler
2025-04-02 10:50     ` Stefan Hanreich
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 09/17] sdn: running: apply fabrics config Gabriel Goller
2025-04-02 10:41   ` Fabian Grünbichler
2025-04-02 12:26     ` Stefan Hanreich
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 10/17] fabrics: generate ifupdown configuration Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 11/17] api: add fabrics subfolder Gabriel Goller
2025-04-02 10:41   ` Fabian Grünbichler
2025-04-02 12:20     ` Stefan Hanreich
2025-04-02 12:29       ` Fabian Grünbichler
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 12/17] api: fabrics: add common helpers Gabriel Goller
2025-04-02 10:41   ` Fabian Grünbichler
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 13/17] fabric: openfabric: add api endpoints Gabriel Goller
2025-04-02 10:37   ` Fabian Grünbichler
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 14/17] fabric: ospf: " Gabriel Goller
2025-04-02 10:37   ` Fabian Grünbichler
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 15/17] test: fabrics: add test cases for ospf and openfabric + evpn Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 16/17] frr: bump frr config version to 10.2.1 Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-network 17/17] frr: fix reloading frr configuration Gabriel Goller
2025-04-02 10:37   ` Fabian Grünbichler
2025-04-02 10:42     ` Stefan Hanreich
2025-03-28 17:13 ` [pve-devel] [PATCH pve-manager 1/7] api: use new generalized frr and etc network config helper functions Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-manager 2/7] fabrics: add common interface panel Gabriel Goller
2025-04-02  9:26   ` Friedrich Weber
2025-04-02 10:04     ` Gabriel Goller
2025-04-02 10:10       ` Friedrich Weber
2025-03-28 17:13 ` [pve-devel] [PATCH pve-manager 3/7] fabrics: add additional interface fields for openfabric and ospf Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-manager 4/7] fabrics: add FabricEdit components Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-manager 5/7] fabrics: add NodeEdit components Gabriel Goller
2025-04-03  9:16   ` Christoph Heiss
2025-04-04 15:45     ` Gabriel Goller [this message]
2025-03-28 17:13 ` [pve-devel] [PATCH pve-manager 6/7] fabrics: Add main FabricView Gabriel Goller
2025-04-02  9:26   ` Friedrich Weber
2025-04-02  9:50   ` Christoph Heiss
2025-04-02 10:40     ` Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-manager 7/7] utils: avoid line-break in pending changes message Gabriel Goller
2025-03-28 17:13 ` [pve-devel] [PATCH pve-docs 1/1] fabrics: add initial documentation for sdn fabrics Gabriel Goller
2025-03-31  8:44   ` Shannon Sterz
2025-03-31 12:24     ` Gabriel Goller
2025-04-02  8:43       ` Gabriel Goller
2025-04-02  8:49   ` Christoph Heiss
2025-04-02  9:09     ` Gabriel Goller
2025-04-02  9:16       ` Christoph Heiss
2025-04-03  8:30 ` [pve-devel] [PATCH cluster/docs/manager/network/proxmox{, -ve-rs, -firewall, -perl-rs} 00/52] Add SDN Fabrics Friedrich Weber
2025-04-03 10:21   ` Gabriel Goller
2025-04-03 13:44     ` Friedrich Weber
2025-04-03 14:03       ` Stefan Hanreich
2025-04-03 14:20         ` Friedrich Weber
2025-04-04  7:53           ` Stefan Hanreich
2025-04-04 10:55 ` Hannes Duerr
2025-04-04 12:48   ` Gabriel Goller
2025-04-04 12:53     ` Hannes Duerr
2025-04-04 14:26       ` Gabriel Goller

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=t4keh3httllbyvgtolbiwqvxwkhjo5htuixhfrs4lsqlrxrc67@exow74p4qhir \
    --to=g.goller@proxmox.com \
    --cc=c.heiss@proxmox.com \
    --cc=pve-devel@lists.proxmox.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Service provided by Proxmox Server Solutions GmbH | Privacy | Legal