From: "Elias Huhsovitz" <e.huhsovitz@proxmox.com>
To: "Dominik Csapak" <d.csapak@proxmox.com>, <pve-devel@lists.proxmox.com>
Subject: Re: [PATCH manager] fix #6211: ui: vm: options: add tooltip to protection option
Date: Thu, 16 Jul 2026 10:09:23 +0200 [thread overview]
Message-ID: <DJZUCE7MVQGZ.2XDIN3VQ457NS@proxmox.com> (raw)
In-Reply-To: <97c1aba3-6dda-4ac0-8935-f0009e453c3a@proxmox.com>
I tried moving the icon to the `boxLabel` as suggested, but in my opinion, it looks a bit off.
Instead of adding a tooltip to clarify the ambiguous "Protection" label, I propose an alternative design decision.
We could rename the option entirely to "Disable VM and Disk removal".
This would make the option self-explanatory and allow us to omit the tooltip altogether.
Let me know your thoughts on this approach.
On Wed Jul 15, 2026 at 2:17 PM CEST, Dominik Csapak wrote:
> would speak anything against putting the icon into the 'boxLabel'
> instead of to the fieldlabel?
>
> that would put it right next to the actual checkbox and not
> to the relatively generic 'enabled' label
> i think our users should now what 'enabled' means, but
> what we want to convey is the meaning of the actual option
>
> On 7/13/26 1:47 PM, Elias Huhsovitz wrote:
>> The "protection" options was ambiguous.
>> Add tooltip to briefly describe the option.
>>
>> Signed-off-by: Elias Huhsovitz <e.huhsovitz@proxmox.com>
>> ---
>> www/manager6/qemu/Options.js | 4 ++++
>> 1 file changed, 4 insertions(+)
>>
>> diff --git a/www/manager6/qemu/Options.js b/www/manager6/qemu/Options.js
>> index 8a4721a0..9ade5ccb 100644
>> --- a/www/manager6/qemu/Options.js
>> +++ b/www/manager6/qemu/Options.js
>> @@ -326,6 +326,10 @@ Ext.define('PVE.qemu.Options', {
>> defaultValue: 0,
>> deleteDefaultValue: true,
>> fieldLabel: gettext('Enabled'),
>> + afterLabelTextTpl: ' <i class="fa fa-question-circle" style="color: #888; cursor: help; margin-left: 4px;"></i>',
>> + autoEl: {
>> + 'data-qtip': gettext('Prevents the VM and its disks from being removed')
>> + }
>> },
>> }
>> : undefined,
next prev parent reply other threads:[~2026-07-16 8:09 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-13 11:46 [PATCH manager] fix #6211: ui: vm: options: add tooltip to protection option Elias Huhsovitz
2026-07-15 12:17 ` Dominik Csapak
2026-07-16 8:09 ` Elias Huhsovitz [this message]
2026-07-16 9:29 ` Dominik Csapak
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=DJZUCE7MVQGZ.2XDIN3VQ457NS@proxmox.com \
--to=e.huhsovitz@proxmox.com \
--cc=d.csapak@proxmox.com \
--cc=pve-devel@lists.proxmox.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox