public inbox for pve-devel@lists.proxmox.com
 help / color / mirror / Atom feed
From: Leo Nunner <l.nunner@proxmox.com>
To: pve-devel@lists.proxmox.com
Subject: [pve-devel] [PATCH firewall manager] Make firewall config case-insensitive
Date: Thu, 26 Jan 2023 15:30:15 +0100	[thread overview]
Message-ID: <20230126143020.150338-1-l.nunner@proxmox.com> (raw)

Until now, the firewall config was quite inconsistent when it came to
capitalization; groups and ipsets were only allowed in lower-case, while
aliases were allowed to retain the original capitalization.

This patch removes all of these restrictions, and instead keeps the
original user-supplied values for groups, ipsets and aliases.
Furthermore, variable naming for rename parameters was cleaned up (due
to touching these lines anyway) and the docs for them were clarified a
bit.

Optionally, this patch also merges group_comments and ipset_comments
with their groups/ipsets into one unified structure.

firewall:

Leo Nunner (4):
  api: factor out renaming parameters to more descriptive names
  docs: clarify usage of 'rename' parameters
  config: make groups, IPSets and aliases case-insensitive
  config: combine group/ipset and their comments

 src/PVE/API2/Firewall/Aliases.pm |  42 +++++++------
 src/PVE/API2/Firewall/Cluster.pm |   2 +-
 src/PVE/API2/Firewall/Groups.pm  |  63 +++++++++----------
 src/PVE/API2/Firewall/IPSet.pm   |  54 ++++++++--------
 src/PVE/API2/Firewall/Rules.pm   |   4 +-
 src/PVE/API2/Firewall/VM.pm      |   2 +-
 src/PVE/Firewall.pm              | 105 +++++++++++++++++--------------
 7 files changed, 144 insertions(+), 128 deletions(-)

manager:

Leo Nunner (1):
  ui: the API doesn't pass 'name' for aliases anymore

 www/manager6/grid/FirewallAliases.js | 1 +
 1 file changed, 1 insertion(+)

-- 
2.30.2





             reply	other threads:[~2023-01-26 14:30 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-01-26 14:30 Leo Nunner [this message]
2023-01-26 14:30 ` [pve-devel] [PATCH firewall 1/4] api: factor out renaming parameters to more descriptive names Leo Nunner
2023-01-27 10:43   ` Wolfgang Bumiller
2023-01-26 14:30 ` [pve-devel] [PATCH firewall 2/4] docs: clarify usage of 'rename' parameters Leo Nunner
2023-01-28 10:39   ` Thomas Lamprecht
2023-01-26 14:30 ` [pve-devel] [PATCH firewall 3/4] config: make groups, IPSets and aliases case-insensitive Leo Nunner
2023-01-26 14:30 ` [pve-devel] [PATCH firewall 4/4] config: combine group/ipset and their comments Leo Nunner
2023-01-27 11:41   ` Wolfgang Bumiller
2023-01-30  9:01     ` Leo Nunner
2023-01-26 14:30 ` [pve-devel] [PATCH manager] ui: the API doesn't pass 'name' for aliases anymore Leo Nunner
2023-01-28 10:43   ` Thomas Lamprecht

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20230126143020.150338-1-l.nunner@proxmox.com \
    --to=l.nunner@proxmox.com \
    --cc=pve-devel@lists.proxmox.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Service provided by Proxmox Server Solutions GmbH | Privacy | Legal