From: "Fabian Grünbichler" <f.gruenbichler@proxmox.com>
To: Proxmox VE development discussion <pve-devel@lists.proxmox.com>
Subject: Re: [pve-devel] [RFC manager 1/1] ui: lvm: expose saferemove setting
Date: Tue, 09 Jan 2024 10:49:05 +0100 [thread overview]
Message-ID: <1704793451.q4m7sde2g1.astroid@yuna.none> (raw)
In-Reply-To: <20231207161038.90626-2-f.ebner@proxmox.com>
On December 7, 2023 5:10 pm, Fiona Ebner wrote:
> It can be security-relevant in some environments. The LVM storage
> documentation can be reached via the "Help" button and contains a few
> more details.
>
> Signed-off-by: Fiona Ebner <f.ebner@proxmox.com>
> ---
> www/manager6/storage/LVMEdit.js | 10 ++++++++++
> 1 file changed, 10 insertions(+)
>
> diff --git a/www/manager6/storage/LVMEdit.js b/www/manager6/storage/LVMEdit.js
> index fde302fc..37d3c6ef 100644
> --- a/www/manager6/storage/LVMEdit.js
> +++ b/www/manager6/storage/LVMEdit.js
> @@ -228,5 +228,15 @@ Ext.define('PVE.storage.LVMInputPanel', {
> uncheckedValue: 0,
> fieldLabel: gettext('Shared'),
> },
> + {
> + xtype: 'proxmoxcheckbox',
> + name: 'saferemove',
> + uncheckedValue: 0,
> + fieldLabel: gettext('Safe Remove'),
> + autoEl: {
> + tag: 'div',
> + 'data-qtip': gettext("Zero-out data when removing LVs"),
IMHO the option is a bit misnamed unfortunately ("Safe Remove" sounds
like something I'd almost always enable - it's "safe" after all ;)).
I am not sure how many users read the tooltips, one possible alternative
would be to make the label sound more dangerous (or rather, use
something there that implies it has a cost), and move the option name
into the tooltip? maybe something like "Wipe removed volumes" could
work?
> + },
> + },
> ],
> });
> --
> 2.39.2
>
>
>
> _______________________________________________
> pve-devel mailing list
> pve-devel@lists.proxmox.com
> https://lists.proxmox.com/cgi-bin/mailman/listinfo/pve-devel
>
>
>
next prev parent reply other threads:[~2024-01-09 9:49 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-12-07 16:10 [pve-devel] [RFC manager/docs] lvm: better expose/explain saferemove option Fiona Ebner
2023-12-07 16:10 ` [pve-devel] [RFC manager 1/1] ui: lvm: expose saferemove setting Fiona Ebner
2024-01-09 9:49 ` Fabian Grünbichler [this message]
2023-12-07 16:10 ` [pve-devel] [PATCH docs 1/1] storage: lvm: expand on description of saferemove option Fiona Ebner
2024-01-09 9:38 ` [pve-devel] applied: " Fabian Grünbichler
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1704793451.q4m7sde2g1.astroid@yuna.none \
--to=f.gruenbichler@proxmox.com \
--cc=pve-devel@lists.proxmox.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox