public inbox for pve-devel@lists.proxmox.com
 help / color / mirror / Atom feed
From: Thomas Lamprecht <t.lamprecht@proxmox.com>
To: Proxmox VE development discussion <pve-devel@lists.proxmox.com>,
	Dominik Csapak <d.csapak@proxmox.com>
Subject: Re: [pve-devel] [PATCH qemu-server v6 5/6] api: create: add 'import-extraction-storage' parameter
Date: Sun, 17 Nov 2024 17:13:27 +0100	[thread overview]
Message-ID: <11e73a57-e108-481e-b2f9-5953e7894799@proxmox.com> (raw)
In-Reply-To: <20241115151749.633407-18-d.csapak@proxmox.com>

Am 15.11.24 um 16:17 schrieb Dominik Csapak:
> this is to override the target extraction storage for the option disk
> extraction for 'import-from'. This way if the storage does not
> supports the content type 'images', one can give an alternative  one.
> 

looks OK to me besides some styling/naming things I commented inline

> Signed-off-by: Dominik Csapak <d.csapak@proxmox.com>
> ---
>  PVE/API2/Qemu.pm | 46 +++++++++++++++++++++++++++++++++++++---------
>  1 file changed, 37 insertions(+), 9 deletions(-)
> 
> diff --git a/PVE/API2/Qemu.pm b/PVE/API2/Qemu.pm
> index 1aa42585..58aaabbe 100644
> --- a/PVE/API2/Qemu.pm
> +++ b/PVE/API2/Qemu.pm
> @@ -174,9 +174,18 @@ my $check_storage_access = sub {
>  		    if $vtype ne 'images' && $vtype ne 'import';
>  
>  		if (PVE::QemuServer::Helpers::needs_extraction($vtype, $fmt)) {
> -		    raise_param_exc({ $ds => "$src_image is not on an storage with 'images' content type."})
> -			if !$scfg->{content}->{images};
> -		    $rpcenv->check($authuser, "/storage/$storeid", ['Datastore.AllocateSpace']);
> +		    if (defined($extraction_storage)) {
> +			my $extraction_scfg = PVE::Storage::storage_config($storecfg, $extraction_storage);
> +			raise_param_exc({ 'import-extraction-storage' => "$extraction_storage does not support"
> +				." 'images' content type or is not file based."})

wrapping two things at once (string and the object/method call parenthesis) is not
ideal readability wise.

> +			if !$extraction_scfg->{content}->{images} || !$extraction_scfg->{path};

please avoid post-ifs on expressions wrapping already multiple lines.

Above could look something like:

if (!$extraction_scfg->{content}->{images} || !$extraction_scfg->{path}) {
    raise_param_exc({
        'import-extraction-storage' => "$extraction_storage does not support"
            ." 'images' content type or is not file based.",
    });
}

> +			$rpcenv->check($authuser, "/storage/$extraction_storage", ['Datastore.AllocateSpace']);
> +		    } else {
> +			raise_param_exc({ $ds => "$src_image is not on an storage with 'images'"
> +			    ." content type and no 'import-extraction-storage' was given."})
> +			    if !$scfg->{content}->{images};

same here, in general you could unfiy the code paths more, they're basically the same,
just need upfront 

my $extraction_scfg = defined($extraction_storage)
    ? PVE::Storage::storage_config($storecfg, $extraction_storage)
    : $scfg;

and
 
$rpcenv->check($authuser, "/storage/" . ($extraction_storage // $storeid), ['Datastore.AllocateSpace']);

IMO it's more gained by more easily seeing that the same things are checked
compared to explicit branches for making loading the extra storage config a bit
more explicit.

> +			$rpcenv->check($authuser, "/storage/$storeid", ['Datastore.AllocateSpace']);
> +		    }
>  		}
>  	    }
>  

> @@ -973,6 +983,12 @@ __PACKAGE__->register_method({
>  		    default => 0,
>  		    description => "Start VM after it was created successfully.",
>  		},
> +		'import-extraction-storage' => get_standard_option('pve-storage-id', {


Would prefer:
import-working-storage

> +		    description => "Storage for temporarily extracted images 'import-from' image"

"images 'import-from' image files" seem like it misses some words in between.

> +			." files (default: import source storage)",

btw. why not prefer the target storage if applicable, i.e. it's a file-storage, and
only fallback to the import one if not? we can change that later though.

But in any way it might be nice to mention that the storage needs to be a file-based
one I think.

Maybe something like:

"A file-based storage with 'images' content-type enabled, into which images are extracted during import as an intermediate step for further processing. Defaults to ..."


> +		    optional => 1,
> +		    completion => \&PVE::QemuServer::complete_storage,
> +		}),
>  	    },
>  	    1, # with_disk_alloc
>  	),

> @@ -2213,6 +2235,12 @@ __PACKAGE__->register_method({
>  		    maximum => 30,
>  		    optional => 1,
>  		},
> +		'import-extraction-storage' => get_standard_option('pve-storage-id', {
> +		    description => "Storage for temporarily extracted images 'import-from' image"
> +			." files (default: import source storage)",

same here as above

> +		    optional => 1,
> +		    completion => \&PVE::QemuServer::complete_storage,
> +		}),
>  	    },
>  	    1, # with_disk_alloc
>  	),



_______________________________________________
pve-devel mailing list
pve-devel@lists.proxmox.com
https://lists.proxmox.com/cgi-bin/mailman/listinfo/pve-devel


  reply	other threads:[~2024-11-17 16:13 UTC|newest]

Thread overview: 67+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-11-15 15:17 [pve-devel] [PATCH storage/qemu-server/manager v6] implement ova/ovf import for file based storages Dominik Csapak
2024-11-15 15:17 ` [pve-devel] [PATCH storage v6 01/12] copy OVF.pm from qemu-server Dominik Csapak
2024-11-17 15:50   ` [pve-devel] applied: " Thomas Lamprecht
2024-11-15 15:17 ` [pve-devel] [PATCH storage v6 02/12] plugin: dir: implement import content type Dominik Csapak
2024-11-18 12:16   ` Fiona Ebner
2024-11-15 15:17 ` [pve-devel] [PATCH storage v6 03/12] plugin: dir: handle ova files for import Dominik Csapak
2024-11-18 12:17   ` Fiona Ebner
2024-11-15 15:17 ` [pve-devel] [PATCH storage v6 04/12] ovf: improve and simplify path checking code Dominik Csapak
2024-11-18 12:25   ` Fiona Ebner
2024-11-15 15:17 ` [pve-devel] [PATCH storage v6 05/12] ovf: implement parsing the ostype Dominik Csapak
2024-11-15 15:17 ` [pve-devel] [PATCH storage v6 06/12] ovf: implement parsing out firmware type Dominik Csapak
2024-11-15 15:17 ` [pve-devel] [PATCH storage v6 07/12] ovf: implement rudimentary boot order Dominik Csapak
2024-11-15 15:17 ` [pve-devel] [PATCH storage v6 08/12] ovf: implement parsing nics Dominik Csapak
2024-11-15 15:17 ` [pve-devel] [PATCH storage v6 09/12] api: allow ova upload/download Dominik Csapak
2024-11-18 12:42   ` Fiona Ebner
2024-11-15 15:17 ` [pve-devel] [PATCH storage v6 10/12] plugin: enable import for nfs/btrfs/cifs/cephfs/glusterfs Dominik Csapak
2024-11-15 15:17 ` [pve-devel] [PATCH storage v6 11/12] add 'import' content type to 'check_volume_access' Dominik Csapak
2024-11-18 12:58   ` Fiona Ebner
2024-11-15 15:17 ` [pve-devel] [PATCH storage v6 12/12] plugin: file_size_info: don't ignore base path with whitespace Dominik Csapak
2024-11-17 15:16   ` Thomas Lamprecht
2024-11-18  7:42     ` Dominik Csapak
2024-11-18  7:48       ` Thomas Lamprecht
2024-11-15 15:17 ` [pve-devel] [PATCH qemu-server v6 1/6] disk import: add additional safeguards for imported image files Dominik Csapak
2024-11-18 13:08   ` Fiona Ebner
2024-11-15 15:17 ` [pve-devel] [PATCH qemu-server v6 2/6] api: delete unused OVF.pm Dominik Csapak
2024-11-17 15:18   ` [pve-devel] applied: " Thomas Lamprecht
2024-11-15 15:17 ` [pve-devel] [PATCH qemu-server v6 3/6] use OVF from Storage Dominik Csapak
2024-11-17 17:42   ` Thomas Lamprecht
2024-11-15 15:17 ` [pve-devel] [PATCH qemu-server v6 4/6] api: create: implement extracting disks when needed for import-from Dominik Csapak
2024-11-18 13:31   ` Fiona Ebner
2024-11-18 13:36     ` Dominik Csapak
2024-11-15 15:17 ` [pve-devel] [PATCH qemu-server v6 5/6] api: create: add 'import-extraction-storage' parameter Dominik Csapak
2024-11-17 16:13   ` Thomas Lamprecht [this message]
2024-11-15 15:17 ` [pve-devel] [PATCH qemu-server v6 6/6] api: check untrusted image files for import content type Dominik Csapak
2024-11-18 14:48   ` Fiona Ebner
2024-11-15 15:17 ` [pve-devel] [PATCH manager v6 1/9] ui: fix special 'import' icon for non-esxi storages Dominik Csapak
2024-11-17 16:21   ` [pve-devel] applied: " Thomas Lamprecht
2024-11-18  8:47     ` Dominik Csapak
2024-11-18  9:56       ` Thomas Lamprecht
2024-11-15 15:17 ` [pve-devel] [PATCH manager v6 2/9] ui: guest import: add ova-needs-extracting warning text Dominik Csapak
2024-11-17 16:29   ` Thomas Lamprecht
2024-11-15 15:17 ` [pve-devel] [PATCH manager v6 3/9] ui: enable import content type for relevant storages Dominik Csapak
2024-11-15 15:17 ` [pve-devel] [PATCH manager v6 4/9] ui: enable upload/download/remove buttons for 'import' type storages Dominik Csapak
2024-11-15 15:17 ` [pve-devel] [PATCH manager v6 5/9] ui: disable 'import' button for non importable formats Dominik Csapak
2024-11-15 15:17 ` [pve-devel] [PATCH manager v6 6/9] ui: import: improve rendering of volume names Dominik Csapak
2024-11-15 15:17 ` [pve-devel] [PATCH manager v6 7/9] ui: guest import: add storage selector for ova extraction storage Dominik Csapak
2024-11-17 16:31   ` Thomas Lamprecht
2024-11-15 15:17 ` [pve-devel] [PATCH manager v6 8/9] ui: guest import: change icon/text for non-esxi import storage Dominik Csapak
2024-11-15 15:17 ` [pve-devel] [PATCH manager v6 9/9] ui: import: show size for dir-based storages Dominik Csapak
2024-11-17 16:37 ` [pve-devel] [PATCH storage/qemu-server/manager v6] implement ova/ovf import for file based storages Thomas Lamprecht
2024-11-18 13:06 ` Lukas Wagner
2024-11-18 13:18   ` Dominik Csapak
2024-11-18 13:39     ` Lukas Wagner
2024-11-18 13:44       ` Dominik Csapak
2024-11-18 13:53         ` Dominik Csapak
2024-11-19  8:15           ` Lukas Wagner
2024-11-19  8:44             ` Dominik Csapak
2024-11-19  8:48             ` Thomas Lamprecht
2024-11-20 16:32               ` Gilberto Ferreira via pve-devel
2024-11-20 16:57                 ` Gilberto Ferreira via pve-devel
2024-11-21  8:24                   ` Dominik Csapak
2024-11-21 12:05                     ` Gilberto Ferreira via pve-devel
2024-11-21 12:23                       ` Gilberto Ferreira via pve-devel
2024-11-21 12:34                         ` Fabian Grünbichler
2024-11-18 14:35 ` Daniel Herzig
2024-11-18 15:01   ` Daniel Herzig
2024-11-18 15:33 ` Dominik Csapak

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=11e73a57-e108-481e-b2f9-5953e7894799@proxmox.com \
    --to=t.lamprecht@proxmox.com \
    --cc=d.csapak@proxmox.com \
    --cc=pve-devel@lists.proxmox.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Service provided by Proxmox Server Solutions GmbH | Privacy | Legal