From: "Max R. Carrara" <m.carrara@proxmox.com>
To: "Robert Obkircher" <r.obkircher@proxmox.com>
Cc: pbs-devel@lists.proxmox.com
Subject: Re: [PATCH proxmox-backup v2 03/10] tape: move tape block structs into separate file module
Date: Mon, 07 Sep 2026 13:44:40 +0200 [thread overview]
Message-ID: <DL9243JY46CB.34BCYGJYSB0NH@proxmox.com> (raw)
In-Reply-To: <178836583425.294173.13392589512957146007.b4-review@b4>
On Wed Sep 2, 2026 at 6:17 PM CEST, Robert Obkircher wrote:
> > ... since a tape block does not really represent a plain buffer.
> >
> > Also rename any private functions mentioning `buffer` along the way.
>
> nit: imo the word buffer immediately makes it clear that the field will
> be used to temporarily store data while it is transfered. The generic
> repeated type name could be something else, like a specific block at
> the start.
Eh, I feel like buffer is way too generic in this case, so I think I'll
just keep it as it is, or maybe use `buffered_block` or something like
that.
next prev parent reply other threads:[~2026-09-07 11:44 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-21 14:02 [PATCH proxmox{,-backup} v2 00/10] Fix Undefined Behavior in Tape Block Header Deallocation Max R. Carrara
2026-08-21 14:02 ` [PATCH proxmox v2 01/10] proxmox-alloc: introduce proxmox-alloc with `LayoutAwareBox<T>` type Max R. Carrara
2026-09-02 16:14 ` Robert Obkircher
2026-09-07 11:44 ` Max R. Carrara
2026-09-07 12:50 ` Robert Obkircher
2026-09-07 13:40 ` Max R. Carrara
2026-08-21 14:02 ` [PATCH proxmox v2 02/10] proxmox-alloc: document undefined behavior regarding custom allocs Max R. Carrara
2026-09-02 16:14 ` Robert Obkircher
2026-09-07 11:44 ` Max R. Carrara
2026-09-02 16:17 ` Robert Obkircher
2026-09-07 11:44 ` Max R. Carrara
2026-08-21 14:02 ` [PATCH proxmox-backup v2 03/10] tape: move tape block structs into separate file module Max R. Carrara
2026-09-02 16:17 ` Robert Obkircher
2026-09-07 11:44 ` Max R. Carrara [this message]
2026-08-21 14:02 ` [PATCH proxmox-backup v2 04/10] tape: rename `BlockHeader` and `BlockHeaderFlags` Max R. Carrara
2026-08-21 14:02 ` [PATCH proxmox-backup v2 05/10] tape: blocked_{reader,writer}: rename `buffer` to `tape_block` Max R. Carrara
2026-08-21 14:02 ` [PATCH proxmox-backup v2 06/10] tape: tape block: represent tape block header with its own struct Max R. Carrara
2026-09-02 16:17 ` Robert Obkircher
2026-09-07 11:44 ` Max R. Carrara
2026-09-07 13:03 ` Robert Obkircher
2026-08-21 14:02 ` [PATCH proxmox-backup v2 07/10] tape: tape block: make `payload` field private Max R. Carrara
2026-08-21 14:02 ` [PATCH proxmox-backup v2 08/10] tape: blocked_{reader,writer}: remove haphazard `unsafe` blocks Max R. Carrara
2026-08-21 14:02 ` [PATCH proxmox-backup v2 09/10] tape: tape block: fix undefined behavior on tape block deallocation Max R. Carrara
2026-08-21 14:02 ` [PATCH proxmox-backup v2 10/10] tape: sgutils2: fix undefined behavior in dealloc of buffer Max R. Carrara
2026-09-02 16:36 ` [PATCH proxmox{,-backup} v2 00/10] Fix Undefined Behavior in Tape Block Header Deallocation Robert Obkircher
2026-09-07 11:44 ` Max R. Carrara
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=DL9243JY46CB.34BCYGJYSB0NH@proxmox.com \
--to=m.carrara@proxmox.com \
--cc=pbs-devel@lists.proxmox.com \
--cc=r.obkircher@proxmox.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox