public inbox for pbs-devel@lists.proxmox.com
 help / color / mirror / Atom feed
From: Christian Ebner <c.ebner@proxmox.com>
To: Proxmox Backup Server development discussion
	<pbs-devel@lists.proxmox.com>,
	Hannes Laimer <h.laimer@proxmox.com>
Subject: Re: [pbs-devel] [PATCH proxmox-backup v3 08/24] api2: disks list: add only-unused flag
Date: Mon, 15 Apr 2024 18:27:14 +0200	[thread overview]
Message-ID: <43d400b0-232b-495a-9d21-de6a0d23c32d@proxmox.com> (raw)
In-Reply-To: <20240409110012.166472-9-h.laimer@proxmox.com>

a few comments inline

On 4/9/24 12:59, Hannes Laimer wrote:
> ... used by the partition selector for removable datastore creation.
> 
> Signed-off-by: Hannes Laimer <h.laimer@proxmox.com>
> ---
>   src/api2/node/disks/mod.rs |  8 +++++
>   src/tools/disks/mod.rs     | 67 +++++++++++++++++++++++++++++++++-----
>   2 files changed, 66 insertions(+), 9 deletions(-)
> 
> diff --git a/src/api2/node/disks/mod.rs b/src/api2/node/disks/mod.rs
> index 711dae7b..bd251dab 100644
> --- a/src/api2/node/disks/mod.rs
> +++ b/src/api2/node/disks/mod.rs
> @@ -41,6 +41,12 @@ pub mod zfs;
>                   optional: true,
>                   default: false,
>               },
> +            "only-unused": {
> +                description: "Only list partitions not used for removable datastores or mounted directories.",

Since the parameter before this one is called `include-partitions`, 
might be worth to keep a similar naming scheme and call this 
`exclude-used` and as description something like `Exclude partitions 
already used for removable datastores or mounted directories.` This 
would also help improve the naming of the `only_not_in_use` variables 
and methods (imho).

> +                type: bool,
> +                optional: true,
> +                default: false,
> +            },
>               "usage-type": {
>                   type: DiskUsageType,
>                   optional: true,
> @@ -62,6 +68,7 @@ pub mod zfs;
>   pub fn list_disks(
>       skipsmart: bool,
>       include_partitions: bool,
> +    only_unused: bool,

with above suggestion, this is renamed to `exclude_used` ...

>       usage_type: Option<DiskUsageType>,
>   ) -> Result<Vec<DiskUsageInfo>, Error> {
>       let mut list = Vec::new();
> @@ -69,6 +76,7 @@ pub fn list_disks(
>       for (_, info) in DiskUsageQuery::new()
>           .smart(!skipsmart)
>           .partitions(include_partitions)
> +        .only_not_in_use(only_unused)

... `exclude_used(exclude_used)`

>           .query()?
>       {
>           if let Some(ref usage_type) = usage_type {
> diff --git a/src/tools/disks/mod.rs b/src/tools/disks/mod.rs
> index eaf016df..81184eb6 100644
> --- a/src/tools/disks/mod.rs
> +++ b/src/tools/disks/mod.rs
> @@ -20,6 +20,7 @@ use proxmox_rest_server::WorkerTask;
>   use proxmox_schema::api;
>   use proxmox_sys::linux::procfs::{mountinfo::Device, MountInfo};
>   use proxmox_sys::task_log;
> +use serde_json::Value;
>   
>   use pbs_api_types::{BLOCKDEVICE_DISK_AND_PARTITION_NAME_REGEX, BLOCKDEVICE_NAME_REGEX};
>   
> @@ -32,6 +33,7 @@ pub use zpool_list::*;
>   mod lvm;
>   pub use lvm::*;
>   mod smart;
> +use crate::api2::node::disks::directory::list_datastore_mounts;
>   pub use smart::*;
>   
>   lazy_static::lazy_static! {
> @@ -828,6 +830,7 @@ fn scan_partitions(
>   pub struct DiskUsageQuery {
>       smart: bool,
>       partitions: bool,
> +    only_not_in_use: bool,
>   }
>   
>   impl DiskUsageQuery {
> @@ -835,6 +838,7 @@ impl DiskUsageQuery {
>           Self {
>               smart: true,
>               partitions: false,
> +            only_not_in_use: false,

... `exclude_used`

>           }
>       }
>   
> @@ -848,12 +852,22 @@ impl DiskUsageQuery {
>           self
>       }
>   
> +    pub fn only_not_in_use(&mut self, only_not_in_use: bool) -> &mut Self {
> +        self.only_not_in_use = only_not_in_use;

... ditto, not going to comment all of them

> +        self
> +    }
> +
>       pub fn query(&self) -> Result<HashMap<String, DiskUsageInfo>, Error> {
> -        get_disks(None, !self.smart, self.partitions)
> +        get_disks(None, !self.smart, self.partitions, self.only_not_in_use)
>       }
>   
>       pub fn find(&self, disk: &str) -> Result<DiskUsageInfo, Error> {
> -        let mut map = get_disks(Some(vec![disk.to_string()]), !self.smart, self.partitions)?;
> +        let mut map = get_disks(
> +            Some(vec![disk.to_string()]),
> +            !self.smart,
> +            self.partitions,
> +            self.only_not_in_use,
> +        )?;
>           if let Some(info) = map.remove(disk) {
>               Ok(info)
>           } else {
> @@ -862,7 +876,12 @@ impl DiskUsageQuery {
>       }
>   
>       pub fn find_all(&self, disks: Vec<String>) -> Result<HashMap<String, DiskUsageInfo>, Error> {
> -        get_disks(Some(disks), !self.smart, self.partitions)
> +        get_disks(
> +            Some(disks),
> +            !self.smart,
> +            self.partitions,
> +            self.only_not_in_use,
> +        )
>       }
>   }
>   
> @@ -935,6 +954,8 @@ fn get_disks(
>       no_smart: bool,
>       // include partitions
>       include_partitions: bool,
> +    // skip partitions which are in use
> +    only_not_in_use: bool,
>   ) -> Result<HashMap<String, DiskUsageInfo>, Error> {
>       let disk_manager = DiskManage::new();
>   
> @@ -952,6 +973,30 @@ fn get_disks(
>   
>       // fixme: ceph journals/volumes
>   
> +    let uuids_in_use = if only_not_in_use && include_partitions {
> +        let (config, _digest) = pbs_config::datastore::config()?;
> +
> +        let uuids_from_datastores: Vec<String> = config
> +            .sections
> +            .iter()
> +            .filter_map(|(_, (_, data))| {
> +                data.as_object()
> +                    .and_then(|cfg| cfg.get("backing-device"))
> +                    .and_then(Value::as_str)
> +                    .map(String::from)
> +            })
> +            .collect();
> +
> +        let uuids_from_mounts: Vec<String> = list_datastore_mounts()?
> +            .into_iter()
> +            .filter_map(|mount| mount.device.split('/').last().map(String::from))
> +            .collect();
> +
> +        [&uuids_from_datastores[..], &uuids_from_mounts[..]].concat()
> +    } else {
> +        Vec::new()
> +    };
> +
>       let mut result = HashMap::new();
>   
>       for item in proxmox_sys::fs::scan_subdir(libc::AT_FDCWD, "/sys/block", &BLOCKDEVICE_NAME_REGEX)?
> @@ -1024,12 +1069,16 @@ fn get_disks(
>   
>           let partitions: Option<Vec<PartitionInfo>> = if include_partitions {
>               disk.partitions().map_or(None, |parts| {
> -                Some(get_partitions_info(
> -                    parts,
> -                    &lvm_devices,
> -                    &zfs_devices,
> -                    &file_system_devices,
> -                ))
> +                let infos =
> +                    get_partitions_info(parts, &lvm_devices, &zfs_devices, &file_system_devices)
> +                        .into_iter()
> +                        .filter(|part| {
> +                            part.uuid
> +                                .as_ref()
> +                                .map_or(true, |u| !uuids_in_use.contains(u))
> +                        })
> +                        .collect();
> +                Some(infos)
>               })
>           } else {
>               None





  reply	other threads:[~2024-04-15 16:27 UTC|newest]

Thread overview: 54+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-04-09 10:59 [pbs-devel] [PATCH proxmox-backup v3 00/24] add removable datastores Hannes Laimer
2024-04-09 10:59 ` [pbs-devel] [PATCH proxmox-backup v3 01/24] tools: add disks utility functions Hannes Laimer
2024-04-09 10:59 ` [pbs-devel] [PATCH proxmox-backup v3 02/24] pbs-api-types: add backing-device to DataStoreConfig Hannes Laimer
2024-04-10  8:13   ` Dietmar Maurer
2024-04-11 10:04   ` Dietmar Maurer
2024-04-15 15:17   ` Christian Ebner
2024-04-09 10:59 ` [pbs-devel] [PATCH proxmox-backup v3 03/24] maintenance: add 'Unpplugged' maintenance type Hannes Laimer
2024-04-11  7:19   ` Dietmar Maurer
2024-04-11  8:16     ` Hannes Laimer
2024-04-09 10:59 ` [pbs-devel] [PATCH proxmox-backup v3 04/24] disks: add UUID to partition info Hannes Laimer
2024-04-09 10:59 ` [pbs-devel] [PATCH proxmox-backup v3 05/24] add helper for checking if a removable datastore is available Hannes Laimer
2024-04-10  8:40   ` Dietmar Maurer
2024-04-15 15:09   ` Christian Ebner
2024-04-16 14:17     ` Hannes Laimer
2024-04-09 10:59 ` [pbs-devel] [PATCH proxmox-backup v3 06/24] api2: admin: add (un)mount endpoint for removable datastores Hannes Laimer
2024-04-10  9:02   ` Dietmar Maurer
2024-04-10  9:08     ` Hannes Laimer
2024-04-10 10:41       ` Dietmar Maurer
2024-04-10  9:12   ` Dietmar Maurer
2024-04-15 15:50   ` Christian Ebner
2024-04-16 14:25     ` Hannes Laimer
2024-04-09 10:59 ` [pbs-devel] [PATCH proxmox-backup v3 07/24] api2: removable datastore creation Hannes Laimer
2024-04-10  9:33   ` Dietmar Maurer
2024-04-15 16:02   ` Christian Ebner
2024-04-16 14:27     ` Hannes Laimer
2024-04-09 10:59 ` [pbs-devel] [PATCH proxmox-backup v3 08/24] api2: disks list: add only-unused flag Hannes Laimer
2024-04-15 16:27   ` Christian Ebner [this message]
2024-04-09 10:59 ` [pbs-devel] [PATCH proxmox-backup v3 09/24] pbs-api-types: datastore: use new proxmox_scheme::de for deserialization Hannes Laimer
2024-04-09 10:59 ` [pbs-devel] [PATCH proxmox-backup v3 10/24] pbs-api-types: add removable/is-available flag to DataStoreListItem Hannes Laimer
2024-04-16  7:37   ` Christian Ebner
2024-04-09 10:59 ` [pbs-devel] [PATCH proxmox-backup v3 11/24] pb-manager: add (un)mount command Hannes Laimer
2024-04-10 10:08   ` Dietmar Maurer
2024-04-16  7:50   ` Christian Ebner
2024-04-09 11:00 ` [pbs-devel] [PATCH proxmox-backup v3 12/24] add auto-mounting for removable datastores Hannes Laimer
2024-04-16  8:05   ` Christian Ebner
2024-04-16 14:39     ` Hannes Laimer
2024-04-16  8:45   ` Christian Ebner
2024-04-09 11:00 ` [pbs-devel] [PATCH proxmox-backup v3 13/24] api: mark removable datastores as unplugged after restart Hannes Laimer
2024-04-10 11:18   ` Dietmar Maurer
2024-04-09 11:00 ` [pbs-devel] [PATCH proxmox-backup v3 14/24] datastore: handle deletion of removable datastore properly Hannes Laimer
2024-04-16  8:10   ` Christian Ebner
2024-04-09 11:00 ` [pbs-devel] [PATCH proxmox-backup v3 15/24] docs: mention maintenance mode reset when removable datastore is unplugged Hannes Laimer
2024-04-09 11:00 ` [pbs-devel] [PATCH proxmox-backup v3 16/24] ui: add partition selector form Hannes Laimer
2024-04-16  8:57   ` Christian Ebner
2024-04-09 11:00 ` [pbs-devel] [PATCH proxmox-backup v3 17/24] ui: add removable datastore creation support Hannes Laimer
2024-04-09 11:00 ` [pbs-devel] [PATCH proxmox-backup v3 18/24] ui: add (un)mount button to summary Hannes Laimer
2024-04-09 11:00 ` [pbs-devel] [PATCH proxmox-backup v3 19/24] ui: display removable datastores in list Hannes Laimer
2024-04-09 11:00 ` [pbs-devel] [PATCH proxmox-backup v3 20/24] ui: utils: render unplugged maintenance mode correctly Hannes Laimer
2024-04-09 11:00 ` [pbs-devel] [PATCH proxmox-backup v3 21/24] ui: utils: make parseMaintenanceMode more robust Hannes Laimer
2024-04-09 11:00 ` [pbs-devel] [PATCH proxmox-backup v3 22/24] ui: add datastore status mask for unplugged removable datastores Hannes Laimer
2024-04-09 11:00 ` [pbs-devel] [PATCH proxmox-backup v3 23/24] ui: maintenance: fix disable msg field if no type is selected Hannes Laimer
2024-04-09 11:00 ` [pbs-devel] [PATCH proxmox-backup v3 24/24] ui: maintenance: disable edit if unplugged Hannes Laimer
2024-04-16  9:37 ` [pbs-devel] [PATCH proxmox-backup v3 00/24] add removable datastores Christian Ebner
2024-04-16 15:03   ` Hannes Laimer

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=43d400b0-232b-495a-9d21-de6a0d23c32d@proxmox.com \
    --to=c.ebner@proxmox.com \
    --cc=h.laimer@proxmox.com \
    --cc=pbs-devel@lists.proxmox.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Service provided by Proxmox Server Solutions GmbH | Privacy | Legal