public inbox for pbs-devel@lists.proxmox.com
 help / color / mirror / Atom feed
From: Wolfgang Bumiller <w.bumiller@proxmox.com>
To: Dominik Csapak <d.csapak@proxmox.com>
Cc: pbs-devel@lists.proxmox.com
Subject: Re: [pbs-devel] [PATCH proxmox] proxmox-schema: add convenience macros for ParameterError
Date: Thu, 3 Mar 2022 13:52:03 +0100	[thread overview]
Message-ID: <20220303125203.vv5mfand3k7ykwxm@olga.proxmox.com> (raw)
In-Reply-To: <20220303115337.3040977-1-d.csapak@proxmox.com>

On Thu, Mar 03, 2022 at 12:53:37PM +0100, Dominik Csapak wrote:
> Signed-off-by: Dominik Csapak <d.csapak@proxmox.com>
> ---
>  proxmox-schema/src/schema.rs | 20 +++++++++++++++++++-
>  1 file changed, 19 insertions(+), 1 deletion(-)
> 
> diff --git a/proxmox-schema/src/schema.rs b/proxmox-schema/src/schema.rs
> index 58c6a82..c568580 100644
> --- a/proxmox-schema/src/schema.rs
> +++ b/proxmox-schema/src/schema.rs
> @@ -21,6 +21,24 @@ pub struct ParameterError {
>      error_list: Vec<(String, Error)>,
>  }
>  
> +/// Like anyhow's `format_err` but producing a `ParameterError`.
> +#[macro_export]
> +macro_rules! format_param_err {

this makes:
- `bail` and `format_err`,
- `io_bail`, `io_format_err`, where `io_` is the common prefix
- `param_bail`, `format_param_err`, where `param_` is in two different places ;-)

please rename this to `param_format_err` for consistency

> +    ($field:expr, $($msg:tt)+) => {
> +        $crate::ParameterError::from(($field, format_err!($($msg)+)))
> +    };
> +}
> +
> +/// Like anyhow's `bail` but enclosing a `ParameterError`, so
> +/// a `downcast` can extract it later. This is useful for
> +/// API calls that need to do parameter checking manually.
> +#[macro_export]
> +macro_rules! param_bail {
> +    ($field:expr, $($msg:tt)+) => {{
> +        return Err($crate::format_param_err!($field, $($msg)+).into());
> +    }};
> +}
> +
>  impl std::error::Error for ParameterError {}
>  
>  impl ParameterError {
> @@ -530,7 +548,7 @@ impl ArraySchema {
>          for (i, item) in list.iter().enumerate() {
>              let result = self.items.verify_json(item);
>              if let Err(err) = result {
> -                return Err(ParameterError::from((format!("[{}]", i), err)).into());
> +                param_bail!(format!("[{}]", i), err);

I don't really like the fact that the `err` which is already an
`anyhow::Error` is now wrapped in an extra `format_err!()` call.
I think this instance should probably not be changed to `param_bail!`.




      reply	other threads:[~2022-03-03 12:52 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-03-03 11:53 Dominik Csapak
2022-03-03 12:52 ` Wolfgang Bumiller [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220303125203.vv5mfand3k7ykwxm@olga.proxmox.com \
    --to=w.bumiller@proxmox.com \
    --cc=d.csapak@proxmox.com \
    --cc=pbs-devel@lists.proxmox.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Service provided by Proxmox Server Solutions GmbH | Privacy | Legal