public inbox for pbs-devel@lists.proxmox.com
 help / color / mirror / Atom feed
* [pbs-devel] [PATCH proxmox-backup] ui: tape: rename 'Datastore' to 'Target Datastore'
@ 2021-05-10 11:19 Dominik Csapak
  2021-05-10 14:57 ` [pbs-devel] applied: " Thomas Lamprecht
  0 siblings, 1 reply; 2+ messages in thread
From: Dominik Csapak @ 2021-05-10 11:19 UTC (permalink / raw)
  To: pbs-devel

we have 2 modi in that window:
* backup has multiple datastores
* backup has single datastore

In the first case we show a 'mapping' grid so that
the user can only restore a part. Here a user sees all source
Datastores and can select a target for each one.

In the second case we only have a single 'Datastore' selector, but
we do not show the source. Because of this, the naming is slightly ambiguous
(is it the 'Source' or the 'Target' ?), so rename it to 'Target Datastore'.

Signed-off-by: Dominik Csapak <d.csapak@proxmox.com>
---
 www/tape/window/TapeRestore.js | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/www/tape/window/TapeRestore.js b/www/tape/window/TapeRestore.js
index 85011cba..edb21668 100644
--- a/www/tape/window/TapeRestore.js
+++ b/www/tape/window/TapeRestore.js
@@ -85,7 +85,7 @@ Ext.define('PBS.TapeManagement.TapeRestoreWindow', {
 		},
 		{
 		    xtype: 'pbsDataStoreSelector',
-		    fieldLabel: gettext('Datastore'),
+		    fieldLabel: gettext('Target Datastore'),
 		    reference: 'defaultDatastore',
 		    name: 'store',
 		    listeners: {
@@ -127,7 +127,7 @@ Ext.define('PBS.TapeManagement.TapeRestoreWindow', {
 	if (!datastores || datastores.length <= 1) {
 	    label.setVisible(false);
 	    grid.setVisible(false);
-	    defaultField.setFieldLabel(gettext('Datastore'));
+	    defaultField.setFieldLabel(gettext('Target Datastore'));
 	    defaultField.setAllowBlank(false);
 	    defaultField.setEmptyText("");
 	    return;
-- 
2.20.1





^ permalink raw reply	[flat|nested] 2+ messages in thread

* [pbs-devel] applied: [PATCH proxmox-backup] ui: tape: rename 'Datastore' to 'Target Datastore'
  2021-05-10 11:19 [pbs-devel] [PATCH proxmox-backup] ui: tape: rename 'Datastore' to 'Target Datastore' Dominik Csapak
@ 2021-05-10 14:57 ` Thomas Lamprecht
  0 siblings, 0 replies; 2+ messages in thread
From: Thomas Lamprecht @ 2021-05-10 14:57 UTC (permalink / raw)
  To: Proxmox Backup Server development discussion, Dominik Csapak

On 10.05.21 13:19, Dominik Csapak wrote:
> we have 2 modi in that window:
> * backup has multiple datastores
> * backup has single datastore
> 
> In the first case we show a 'mapping' grid so that
> the user can only restore a part. Here a user sees all source
> Datastores and can select a target for each one.
> 
> In the second case we only have a single 'Datastore' selector, but
> we do not show the source. Because of this, the naming is slightly ambiguous
> (is it the 'Source' or the 'Target' ?), so rename it to 'Target Datastore'.
> 
> Signed-off-by: Dominik Csapak <d.csapak@proxmox.com>
> ---
>  www/tape/window/TapeRestore.js | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
>

applied, thanks!




^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-05-10 14:57 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-05-10 11:19 [pbs-devel] [PATCH proxmox-backup] ui: tape: rename 'Datastore' to 'Target Datastore' Dominik Csapak
2021-05-10 14:57 ` [pbs-devel] applied: " Thomas Lamprecht

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Service provided by Proxmox Server Solutions GmbH | Privacy | Legal