public inbox for pbs-devel@lists.proxmox.com
 help / color / mirror / Atom feed
From: "Fabian Grünbichler" <f.gruenbichler@proxmox.com>
To: Proxmox Backup Server development discussion
	<pbs-devel@lists.proxmox.com>
Subject: Re: [pbs-devel] [PATCH proxmox-backup v12 11/26] bin: manager: add (un)mount command
Date: Wed, 30 Oct 2024 11:13:39 +0100	[thread overview]
Message-ID: <173028321972.67540.1236723641085948040@yuna.proxmox.com> (raw)
In-Reply-To: <D58EJ7ESGLGO.14KYX4WOQEULE@proxmox.com>

Quoting Hannes Laimer (2024-10-29 16:40:22)
> On Mon Oct 14, 2024 at 3:42 PM CEST, Fabian Grünbichler wrote:
> > On September 4, 2024 4:11 pm, Hannes Laimer wrote:
> > > Signed-off-by: Hannes Laimer <h.laimer@proxmox.com>
> > > ---
> > >  pbs-config/src/datastore.rs                 | 14 ++++
> > >  src/bin/proxmox_backup_manager/datastore.rs | 76 ++++++++++++++++++++-
> > >  2 files changed, 89 insertions(+), 1 deletion(-)
> > > 
> > > diff --git a/pbs-config/src/datastore.rs b/pbs-config/src/datastore.rs
> > > index dc5bb3da..396dcb37 100644
> > > --- a/pbs-config/src/datastore.rs
> > > +++ b/pbs-config/src/datastore.rs
> > > @@ -62,6 +62,20 @@ pub fn complete_datastore_name(_arg: &str, _param: &HashMap<String, String>) ->
> > >      }
> > >  }
> > >  
> > > +pub fn complete_removable_datastore_name(
> > > +    _arg: &str,
> > > +    _param: &HashMap<String, String>,
> > > +) -> Vec<String> {
> > > +    match config() {
> > > +        Ok((data, _digest)) => data
> > > +            .sections
> > > +            .into_iter()
> > > +            .filter_map(|(name, (_, c))| c.get("backing-device").map(|_| name))
> >
> > nit: I'd prefer `.and(Some(name))`` instead of mapping just to throw the
> > value away
> >
> > > +            .collect(),
> > > +        Err(_) => Vec::new(),
> > > +    }
> > > +}
> > > +
> > >  pub fn complete_acl_path(_arg: &str, _param: &HashMap<String, String>) -> Vec<String> {
> > >      let mut list = vec![
> > >          String::from("/"),
> > > diff --git a/src/bin/proxmox_backup_manager/datastore.rs b/src/bin/proxmox_backup_manager/datastore.rs
> > > index 383bcd24..f2795b39 100644
> > > --- a/src/bin/proxmox_backup_manager/datastore.rs
> > > +++ b/src/bin/proxmox_backup_manager/datastore.rs
> > > @@ -1,4 +1,4 @@
> > > -use anyhow::Error;
> > > +use anyhow::{format_err, Error};
> > >  use serde_json::Value;
> > >  
> > >  use proxmox_router::{cli::*, ApiHandler, RpcEnvironment};
> > > @@ -40,6 +40,34 @@ fn list_datastores(param: Value, rpcenv: &mut dyn RpcEnvironment) -> Result<Valu
> > >      Ok(Value::Null)
> > >  }
> > >  
> > > +#[api(
> > > +    protected: true,
> > > +    input: {
> > > +        properties: {
> > > +            store: {
> > > +                schema: DATASTORE_SCHEMA,
> > > +            },
> > > +            digest: {
> > > +                optional: true,
> > > +                schema: PROXMOX_CONFIG_DIGEST_SCHEMA,
> > > +            },
> > > +        },
> > > +    },
> > > +)]
> > > +/// Mount a removable datastore.
> > > +async fn mount_datastore(mut param: Value, rpcenv: &mut dyn RpcEnvironment) -> Result<(), Error> {
> >
> > why can't this just delegate directly to the API endpoint? (if there is
> > a reason, it would be nice to mention such things in the commit
> > message..)
> >
> 
> The mounting is done by a worker, and this worker has its parent (the CLI bin)
> killed once it started the worker and finished. [1]
> 
> [1] https://lore.proxmox.com/pbs-devel/2bcb9be3-b4cf-450b-8cf1-1e74b49a58f2@proxmox.com/#t

ah, we ran into that recently with some other datastore maintenance related
task.

seems like this could/should be fixed in the CLI handler? but in the meantime,
if you need to workaround such limitations note them somewhere please..


_______________________________________________
pbs-devel mailing list
pbs-devel@lists.proxmox.com
https://lists.proxmox.com/cgi-bin/mailman/listinfo/pbs-devel

  reply	other threads:[~2024-10-30 10:13 UTC|newest]

Thread overview: 55+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-09-04 14:11 [pbs-devel] [PATCH proxmox-backup v12 00/26] add removable datastores Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 01/26] tools: add disks utility functions Hannes Laimer
2024-10-14 13:42   ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 02/26] config: factor out method to get the absolute datastore path Hannes Laimer
2024-10-14 13:42   ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 03/26] pbs-api-types: add backing-device to DataStoreConfig Hannes Laimer
2024-10-14 13:42   ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 04/26] maintenance: add 'Unmount' maintenance type Hannes Laimer
2024-10-14 13:42   ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 05/26] disks: add UUID to partition info Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 06/26] datastore: add helper for checking if a removable datastore is available Hannes Laimer
2024-10-14 13:42   ` Fabian Grünbichler
2024-10-29 14:04     ` Hannes Laimer
2024-10-30  9:45       ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 07/26] api: admin: add (un)mount endpoint for removable datastores Hannes Laimer
2024-10-14 13:42   ` Fabian Grünbichler
2024-10-29 14:58     ` Hannes Laimer
2024-10-30 10:07       ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 08/26] api: removable datastore creation Hannes Laimer
2024-10-14 13:42   ` Fabian Grünbichler
2024-10-29 15:15     ` Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 09/26] api: disks list: add exclude-used flag Hannes Laimer
2024-10-14 13:42   ` Fabian Grünbichler
2024-10-29 15:17     ` Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 10/26] pbs-api-types: add removable/is-available flag to DataStoreListItem Hannes Laimer
2024-10-14 13:42   ` Fabian Grünbichler
2024-10-29 15:21     ` Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 11/26] bin: manager: add (un)mount command Hannes Laimer
2024-10-14 13:42   ` Fabian Grünbichler
2024-10-29 15:40     ` Hannes Laimer
2024-10-30 10:13       ` Fabian Grünbichler [this message]
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 12/26] add auto-mounting for removable datastores Hannes Laimer
2024-10-14 13:42   ` Fabian Grünbichler
2024-10-29 15:52     ` Hannes Laimer
2024-10-30 10:21       ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 13/26] datastore: handle deletion of removable datastore properly Hannes Laimer
2024-10-14 13:42   ` Fabian Grünbichler
2024-10-29 16:15     ` Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 14/26] docs: add removable datastores section Hannes Laimer
2024-10-14 13:42   ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 15/26] ui: add partition selector form Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 16/26] ui: add removable datastore creation support Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 17/26] ui: add (un)mount button to summary Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 18/26] ui: tree: render unmounted datastores correctly Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 19/26] ui: utils: make parseMaintenanceMode more robust Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 20/26] ui: add datastore status mask for unmounted removable datastores Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 21/26] ui: maintenance: fix disable msg field if no type is selected Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 22/26] ui: render 'unmount' maintenance mode correctly Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 23/26] api: node: allow creation of removable datastore through directory endpoint Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 24/26] api: node: include removable datastores in directory list Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 25/26] node: disks: replace BASE_MOUNT_DIR with DATASTORE_MOUNT_DIR Hannes Laimer
2024-10-14 13:43   ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 26/26] ui: support create removable datastore through directory creation Hannes Laimer
2024-10-14 13:43 ` [pbs-devel] [PATCH proxmox-backup v12 00/26] add removable datastores Fabian Grünbichler
2024-10-29 16:18   ` Hannes Laimer

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=173028321972.67540.1236723641085948040@yuna.proxmox.com \
    --to=f.gruenbichler@proxmox.com \
    --cc=pbs-devel@lists.proxmox.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Service provided by Proxmox Server Solutions GmbH | Privacy | Legal