From: "Fabian Grünbichler" <f.gruenbichler@proxmox.com>
To: Proxmox Backup Server development discussion
<pbs-devel@lists.proxmox.com>
Subject: Re: [pbs-devel] [PATCH proxmox-backup v12 11/26] bin: manager: add (un)mount command
Date: Mon, 14 Oct 2024 15:42:54 +0200 [thread overview]
Message-ID: <1728910495.gtwf1rxw2w.astroid@yuna.none> (raw)
In-Reply-To: <20240904141155.350454-12-h.laimer@proxmox.com>
On September 4, 2024 4:11 pm, Hannes Laimer wrote:
> Signed-off-by: Hannes Laimer <h.laimer@proxmox.com>
> ---
> pbs-config/src/datastore.rs | 14 ++++
> src/bin/proxmox_backup_manager/datastore.rs | 76 ++++++++++++++++++++-
> 2 files changed, 89 insertions(+), 1 deletion(-)
>
> diff --git a/pbs-config/src/datastore.rs b/pbs-config/src/datastore.rs
> index dc5bb3da..396dcb37 100644
> --- a/pbs-config/src/datastore.rs
> +++ b/pbs-config/src/datastore.rs
> @@ -62,6 +62,20 @@ pub fn complete_datastore_name(_arg: &str, _param: &HashMap<String, String>) ->
> }
> }
>
> +pub fn complete_removable_datastore_name(
> + _arg: &str,
> + _param: &HashMap<String, String>,
> +) -> Vec<String> {
> + match config() {
> + Ok((data, _digest)) => data
> + .sections
> + .into_iter()
> + .filter_map(|(name, (_, c))| c.get("backing-device").map(|_| name))
nit: I'd prefer `.and(Some(name))`` instead of mapping just to throw the
value away
> + .collect(),
> + Err(_) => Vec::new(),
> + }
> +}
> +
> pub fn complete_acl_path(_arg: &str, _param: &HashMap<String, String>) -> Vec<String> {
> let mut list = vec![
> String::from("/"),
> diff --git a/src/bin/proxmox_backup_manager/datastore.rs b/src/bin/proxmox_backup_manager/datastore.rs
> index 383bcd24..f2795b39 100644
> --- a/src/bin/proxmox_backup_manager/datastore.rs
> +++ b/src/bin/proxmox_backup_manager/datastore.rs
> @@ -1,4 +1,4 @@
> -use anyhow::Error;
> +use anyhow::{format_err, Error};
> use serde_json::Value;
>
> use proxmox_router::{cli::*, ApiHandler, RpcEnvironment};
> @@ -40,6 +40,34 @@ fn list_datastores(param: Value, rpcenv: &mut dyn RpcEnvironment) -> Result<Valu
> Ok(Value::Null)
> }
>
> +#[api(
> + protected: true,
> + input: {
> + properties: {
> + store: {
> + schema: DATASTORE_SCHEMA,
> + },
> + digest: {
> + optional: true,
> + schema: PROXMOX_CONFIG_DIGEST_SCHEMA,
> + },
> + },
> + },
> +)]
> +/// Mount a removable datastore.
> +async fn mount_datastore(mut param: Value, rpcenv: &mut dyn RpcEnvironment) -> Result<(), Error> {
why can't this just delegate directly to the API endpoint? (if there is
a reason, it would be nice to mention such things in the commit
message..)
> + param["node"] = "localhost".into();
> +
> + let info = &api2::admin::datastore::API_METHOD_MOUNT;
> + let result = match info.handler {
> + ApiHandler::Sync(handler) => (handler)(param, info, rpcenv)?,
> + _ => unreachable!(),
> + };
> +
> + crate::wait_for_local_worker(result.as_str().unwrap()).await?;
> + Ok(())
> +}
> +
> #[api(
> input: {
> properties: {
> @@ -99,6 +127,34 @@ async fn create_datastore(mut param: Value) -> Result<Value, Error> {
> Ok(Value::Null)
> }
>
> +#[api(
> + protected: true,
> + input: {
> + properties: {
> + store: {
> + schema: DATASTORE_SCHEMA,
> + },
> + digest: {
> + optional: true,
> + schema: PROXMOX_CONFIG_DIGEST_SCHEMA,
> + },
> + },
> + },
> +)]
> +/// Unmount a removable datastore.
> +async fn unmount_datastore(mut param: Value, rpcenv: &mut dyn RpcEnvironment) -> Result<(), Error> {
same question here?
> + param["node"] = "localhost".into();
> +
> + let info = &api2::admin::datastore::API_METHOD_UNMOUNT;
> + let result = match info.handler {
> + ApiHandler::Async(handler) => (handler)(param, info, rpcenv).await?,
> + _ => unreachable!(),
> + };
> +
> + crate::wait_for_local_worker(result.as_str().unwrap()).await?;
> + Ok(())
> +}
> +
> #[api(
> protected: true,
> input: {
> @@ -142,6 +198,15 @@ async fn delete_datastore(mut param: Value, rpcenv: &mut dyn RpcEnvironment) ->
> pub fn datastore_commands() -> CommandLineInterface {
> let cmd_def = CliCommandMap::new()
> .insert("list", CliCommand::new(&API_METHOD_LIST_DATASTORES))
> + .insert(
> + "mount",
> + CliCommand::new(&API_METHOD_MOUNT_DATASTORE)
> + .arg_param(&["store"])
> + .completion_cb(
> + "store",
> + pbs_config::datastore::complete_removable_datastore_name,
> + ),
> + )
> .insert(
> "show",
> CliCommand::new(&API_METHOD_SHOW_DATASTORE)
> @@ -152,6 +217,15 @@ pub fn datastore_commands() -> CommandLineInterface {
> "create",
> CliCommand::new(&API_METHOD_CREATE_DATASTORE).arg_param(&["name", "path"]),
> )
> + .insert(
> + "unmount",
> + CliCommand::new(&API_METHOD_UNMOUNT_DATASTORE)
> + .arg_param(&["store"])
> + .completion_cb(
> + "store",
> + pbs_config::datastore::complete_removable_datastore_name,
> + ),
> + )
> .insert(
> "update",
> CliCommand::new(&api2::config::datastore::API_METHOD_UPDATE_DATASTORE)
> --
> 2.39.2
>
>
>
> _______________________________________________
> pbs-devel mailing list
> pbs-devel@lists.proxmox.com
> https://lists.proxmox.com/cgi-bin/mailman/listinfo/pbs-devel
>
>
>
_______________________________________________
pbs-devel mailing list
pbs-devel@lists.proxmox.com
https://lists.proxmox.com/cgi-bin/mailman/listinfo/pbs-devel
next prev parent reply other threads:[~2024-10-14 13:42 UTC|newest]
Thread overview: 55+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-09-04 14:11 [pbs-devel] [PATCH proxmox-backup v12 00/26] add removable datastores Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 01/26] tools: add disks utility functions Hannes Laimer
2024-10-14 13:42 ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 02/26] config: factor out method to get the absolute datastore path Hannes Laimer
2024-10-14 13:42 ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 03/26] pbs-api-types: add backing-device to DataStoreConfig Hannes Laimer
2024-10-14 13:42 ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 04/26] maintenance: add 'Unmount' maintenance type Hannes Laimer
2024-10-14 13:42 ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 05/26] disks: add UUID to partition info Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 06/26] datastore: add helper for checking if a removable datastore is available Hannes Laimer
2024-10-14 13:42 ` Fabian Grünbichler
2024-10-29 14:04 ` Hannes Laimer
2024-10-30 9:45 ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 07/26] api: admin: add (un)mount endpoint for removable datastores Hannes Laimer
2024-10-14 13:42 ` Fabian Grünbichler
2024-10-29 14:58 ` Hannes Laimer
2024-10-30 10:07 ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 08/26] api: removable datastore creation Hannes Laimer
2024-10-14 13:42 ` Fabian Grünbichler
2024-10-29 15:15 ` Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 09/26] api: disks list: add exclude-used flag Hannes Laimer
2024-10-14 13:42 ` Fabian Grünbichler
2024-10-29 15:17 ` Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 10/26] pbs-api-types: add removable/is-available flag to DataStoreListItem Hannes Laimer
2024-10-14 13:42 ` Fabian Grünbichler
2024-10-29 15:21 ` Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 11/26] bin: manager: add (un)mount command Hannes Laimer
2024-10-14 13:42 ` Fabian Grünbichler [this message]
2024-10-29 15:40 ` Hannes Laimer
2024-10-30 10:13 ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 12/26] add auto-mounting for removable datastores Hannes Laimer
2024-10-14 13:42 ` Fabian Grünbichler
2024-10-29 15:52 ` Hannes Laimer
2024-10-30 10:21 ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 13/26] datastore: handle deletion of removable datastore properly Hannes Laimer
2024-10-14 13:42 ` Fabian Grünbichler
2024-10-29 16:15 ` Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 14/26] docs: add removable datastores section Hannes Laimer
2024-10-14 13:42 ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 15/26] ui: add partition selector form Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 16/26] ui: add removable datastore creation support Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 17/26] ui: add (un)mount button to summary Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 18/26] ui: tree: render unmounted datastores correctly Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 19/26] ui: utils: make parseMaintenanceMode more robust Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 20/26] ui: add datastore status mask for unmounted removable datastores Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 21/26] ui: maintenance: fix disable msg field if no type is selected Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 22/26] ui: render 'unmount' maintenance mode correctly Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 23/26] api: node: allow creation of removable datastore through directory endpoint Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 24/26] api: node: include removable datastores in directory list Hannes Laimer
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 25/26] node: disks: replace BASE_MOUNT_DIR with DATASTORE_MOUNT_DIR Hannes Laimer
2024-10-14 13:43 ` Fabian Grünbichler
2024-09-04 14:11 ` [pbs-devel] [PATCH proxmox-backup v12 26/26] ui: support create removable datastore through directory creation Hannes Laimer
2024-10-14 13:43 ` [pbs-devel] [PATCH proxmox-backup v12 00/26] add removable datastores Fabian Grünbichler
2024-10-29 16:18 ` Hannes Laimer
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1728910495.gtwf1rxw2w.astroid@yuna.none \
--to=f.gruenbichler@proxmox.com \
--cc=pbs-devel@lists.proxmox.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox