From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from gate001.proxmox.com (gate001.proxmox.com [45.144.208.40]) by lore.proxmox.com (Postfix) with ESMTPS id 85ADE1FF0A5 for ; Fri, 04 Sep 2026 13:47:53 +0200 (CEST) Received: from gate001.proxmox.com (localhost.localdomain [127.0.0.1]) by gate001.proxmox.com (Proxmox) with ESMTP id 8235F215BD; Fri, 04 Sep 2026 13:47:49 +0200 (CEST) Message-ID: Date: Fri, 4 Sep 2026 13:47:44 +0200 MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Beta Subject: Re: [PATCH qemu-server v4 4/7] pci: factor 'prepare_pci_devices' out to PVE::QemuServer::PCI module To: Jakob Klocker , pve-devel@lists.proxmox.com References: <20260825135502.3971930-1-d.csapak@proxmox.com> <20260825135502.3971930-5-d.csapak@proxmox.com> Content-Language: en-US From: Dominik Csapak In-Reply-To: Content-Type: text/plain; charset=UTF-8; format=flowed Content-Transfer-Encoding: 7bit X-Bm-Milter-Handled: 55990f41-d878-4baa-be0a-ee34c49e34d2 X-Bm-Transport-Timestamp: 1788522461011 X-SPAM-LEVEL: Spam detection results: 0 AWL -0.460 Adjusted score from AWL reputation of From: address DMARC_MISSING 0.1 Missing DMARC policy KAM_DMARC_STATUS 0.01 Test Rule for DKIM or SPF Failure with Strict Alignment (newer systems) KAM_MAILER 2 Automated Mailer Tag Left in Email RCVD_IN_DNSWL_MED -2.3 Sender listed at https://www.dnswl.org/, medium trust SPF_HELO_NONE 0.001 SPF: HELO does not publish an SPF Record SPF_PASS -0.001 SPF: sender matches SPF record Message-ID-Hash: CTXPHZQMYX7C3CDC3DRNPUXURDWLCCRL X-Message-ID-Hash: CTXPHZQMYX7C3CDC3DRNPUXURDWLCCRL X-MailFrom: d.csapak@proxmox.com X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header X-Mailman-Version: 3.3.10 Precedence: list List-Id: Proxmox VE development discussion List-Help: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: On 9/3/26 10:53 AM, Jakob Klocker wrote: > nit inline > On Tue Aug 25, 2026 at 3:54 PM CEST, Dominik Csapak wrote: >> no functional change intended. >> >> Note: $conf is unused in `prepare_pci_devices` for now, but will be used >> later. >> >> Signed-off-by: Dominik Csapak >> --- >> src/PVE/QemuServer.pm | 36 ++------------------------------- >> src/PVE/QemuServer/PCI.pm | 42 +++++++++++++++++++++++++++++++++++++++ >> 2 files changed, 44 insertions(+), 34 deletions(-) >> >> diff --git a/src/PVE/QemuServer.pm b/src/PVE/QemuServer.pm >> index 9c4c13b9..3eeea871 100644 >> --- a/src/PVE/QemuServer.pm >> +++ b/src/PVE/QemuServer.pm >> @@ -5697,40 +5697,8 @@ sub vm_start_nolock { >> >> push $cmd->@*, $state_cmdline->@*; >> >> - for my $device (values $pci_devices->%*) { >> - next if $device->{mdev}; # we don't reserve for mdev devices >> - push $pci_reserve_list->@*, map { $_->{id} } $device->{ids}->@*; >> - } >> - >> - # reserve all PCI IDs before actually doing anything with them >> - PVE::QemuServer::PCI::reserve_pci_usage($pci_reserve_list, $vmid, $start_timeout); >> - >> - my $uuid; >> - for my $id (sort keys %$pci_devices) { >> - my $d = $pci_devices->{$id}; >> - my ($index) = ($id =~ m/^hostpci(\d+)$/); >> - >> - my $chosen_mdev; >> - for my $dev ($d->{ids}->@*) { >> - my $info = >> - eval { PVE::QemuServer::PCI::prepare_pci_device($vmid, $dev->{id}, $index, $d) }; >> - if ($d->{mdev} || $d->{nvidia}) { >> - warn $@ if $@; >> - $chosen_mdev = $info; >> - last if $chosen_mdev; # if successful, we're done >> - } else { >> - die $@ if $@; >> - } >> - } >> - >> - next if !$d->{mdev} && !$d->{nvidia}; >> - die "could not create mediated device\n" if !defined($chosen_mdev); >> - >> - # nvidia vgpu needs a uuid as qemu parameter >> - if (!defined($uuid) && $chosen_mdev->{vendor} =~ m/^(0x)?10de$/) { >> - $uuid = PVE::QemuServer::PCI::Mdev::generate_mdev_uuid($vmid, $index); >> - } >> - } >> + ($pci_reserve_list, my $uuid) = >> + PVE::QemuServer::PCI::prepare_pci_devices($conf, $vmid, $pci_devices, $start_timeout); >> >> # uuid for nvidia vgpu >> # prefer the smbios1 uuid if we have and need it >> diff --git a/src/PVE/QemuServer/PCI.pm b/src/PVE/QemuServer/PCI.pm >> index 0b67943c..f7167dcc 100644 >> --- a/src/PVE/QemuServer/PCI.pm >> +++ b/src/PVE/QemuServer/PCI.pm >> @@ -704,6 +704,48 @@ sub print_hostpci_devices { >> return ($kvm_off, $gpu_passthrough, $legacy_igd, $pci_devices); >> } >> >> +sub prepare_pci_devices { >> + my ($conf, $vmid, $pci_devices, $start_timeout) = @_; >> + >> + my $pci_reserve_list = []; >> + my $uuid; >> + >> + for my $device (values $pci_devices->%*) { >> + next if $device->{mdev}; # we don't reserve for mdev devices >> + push $pci_reserve_list->@*, map { $_->{id} } $device->{ids}->@*; >> + } >> + >> + # reserve all PCI IDs before actually doing anything with them >> + reserve_pci_usage($pci_reserve_list, $vmid, $start_timeout); >> + >> + for my $id (sort keys %$pci_devices) { >> + my $d = $pci_devices->{$id}; > > Since this code is being moved anyway, it might be a good opportunity > to give $d a more descriptive name. Since $device is already in use, > maybe $pci_device? Since this patchs is only loosely related to the series (i only need it at a different point) i'd send a follow-up for that instead of a new version of the series > >> + my ($index) = ($id =~ m/^hostpci(\d+)$/); >> + >> + my $chosen_mdev; >> + for my $dev ($d->{ids}->@*) { >> + my $info = eval { prepare_pci_device($vmid, $dev->{id}, $index, $d) }; >> + if ($d->{mdev} || $d->{nvidia}) { >> + warn $@ if $@; >> + $chosen_mdev = $info; >> + last if $chosen_mdev; # if successful, we're done >> + } else { >> + die $@ if $@; >> + } >> + } >> + >> + next if !$d->{mdev} && !$d->{nvidia}; >> + die "could not create mediated device\n" if !defined($chosen_mdev); >> + >> + # nvidia vgpu needs a uuid as qemu parameter >> + if (!defined($uuid) && $chosen_mdev->{vendor} =~ m/^(0x)?10de$/) { >> + $uuid = PVE::QemuServer::PCI::Mdev::generate_mdev_uuid($vmid, $index); >> + } >> + } >> + >> + return ($pci_reserve_list, $uuid); >> +} >> + >> sub prepare_pci_device { >> my ($vmid, $pciid, $index, $device) = @_; >> >