From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from firstgate.proxmox.com (firstgate.proxmox.com [212.224.123.68]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits)) (No client certificate requested) by lists.proxmox.com (Postfix) with ESMTPS id D4FC2747A8 for ; Wed, 2 Jun 2021 10:36:51 +0200 (CEST) Received: from firstgate.proxmox.com (localhost [127.0.0.1]) by firstgate.proxmox.com (Proxmox) with ESMTP id C578088E5 for ; Wed, 2 Jun 2021 10:36:51 +0200 (CEST) Received: from proxmox-new.maurer-it.com (proxmox-new.maurer-it.com [94.136.29.106]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits)) (No client certificate requested) by firstgate.proxmox.com (Proxmox) with ESMTPS id 3CEF088D8 for ; Wed, 2 Jun 2021 10:36:46 +0200 (CEST) Received: from proxmox-new.maurer-it.com (localhost.localdomain [127.0.0.1]) by proxmox-new.maurer-it.com (Proxmox) with ESMTP id 0BECF466E4 for ; Wed, 2 Jun 2021 10:36:46 +0200 (CEST) To: pve-devel@lists.proxmox.com, Aaron Lauterer References: <20210601161025.32024-1-a.lauterer@proxmox.com> <20210601161025.32024-3-a.lauterer@proxmox.com> From: Fabian Ebner Message-ID: Date: Wed, 2 Jun 2021 10:36:44 +0200 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.10.0 MIME-Version: 1.0 In-Reply-To: <20210601161025.32024-3-a.lauterer@proxmox.com> Content-Type: text/plain; charset=utf-8; format=flowed Content-Language: en-US Content-Transfer-Encoding: 7bit X-SPAM-LEVEL: Spam detection results: 0 AWL 0.291 Adjusted score from AWL reputation of From: address KAM_DMARC_STATUS 0.01 Test Rule for DKIM or SPF Failure with Strict Alignment KAM_SHORT 0.001 Use of a URL Shortener for very short URL NICE_REPLY_A -0.613 Looks like a legit reply (A) SPF_HELO_NONE 0.001 SPF: HELO does not publish an SPF Record SPF_PASS -0.001 SPF: sender matches SPF record URIBL_BLOCKED 0.001 ADMINISTRATOR NOTICE: The query to URIBL was blocked. See http://wiki.apache.org/spamassassin/DnsBlocklists#dnsbl-block for more information. [lvmplugin.pm, rbdplugin.pm, storage.pm, plugin.pm, gnu.org, lvmthinplugin.pm, zfspoolplugin.pm] Subject: Re: [pve-devel] [RFC storage 2/7] add disk rename feature X-BeenThere: pve-devel@lists.proxmox.com X-Mailman-Version: 2.1.29 Precedence: list List-Id: Proxmox VE development discussion List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Wed, 02 Jun 2021 08:36:51 -0000 Am 01.06.21 um 18:10 schrieb Aaron Lauterer: > Functionality has been added for the following storage types: > > * dir based ones > * directory > * NFS > * CIFS > * gluster > * ZFS > * (thin) LVM > * Ceph > > A new feature `rename` has been introduced to mark which storage > plugin supports the feature. > > Version API and AGE have been bumped. > > Signed-off-by: Aaron Lauterer > --- > changes: > only do rename now but the rename function handles templates and returns > the new volid as this can be differently handled on some storages. > > PVE/Storage.pm | 19 +++++++++++++++++-- > PVE/Storage/LVMPlugin.pm | 18 ++++++++++++++++++ > PVE/Storage/LvmThinPlugin.pm | 1 + > PVE/Storage/Plugin.pm | 29 +++++++++++++++++++++++++++++ > PVE/Storage/RBDPlugin.pm | 16 ++++++++++++++++ > PVE/Storage/ZFSPoolPlugin.pm | 12 ++++++++++++ > 6 files changed, 93 insertions(+), 2 deletions(-) > > diff --git a/PVE/Storage.pm b/PVE/Storage.pm > index 93d09ce..6936abd 100755 > --- a/PVE/Storage.pm > +++ b/PVE/Storage.pm > @@ -40,11 +40,11 @@ use PVE::Storage::ZFSPlugin; > use PVE::Storage::PBSPlugin; > > # Storage API version. Increment it on changes in storage API interface. > -use constant APIVER => 8; > +use constant APIVER => 9; > # Age is the number of versions we're backward compatible with. > # This is like having 'current=APIVER' and age='APIAGE' in libtool, > # see https://www.gnu.org/software/libtool/manual/html_node/Libtool-versioning.html > -use constant APIAGE => 7; > +use constant APIAGE => 8; > > # load standard plugins > PVE::Storage::DirPlugin->register(); > @@ -355,6 +355,7 @@ sub volume_snapshot_needs_fsfreeze { > # snapshot - taking a snapshot is possible > # sparseinit - volume is sparsely initialized > # template - conversion to base image is possible > +# rename - renaming volumes is possible > # $snap - check if the feature is supported for a given snapshot > # $running - if the guest owning the volume is running > # $opts - hash with further options: > @@ -1849,6 +1850,20 @@ sub complete_volume { > return $res; > } > > +sub rename_volume { > + my ($cfg, $source_volid, $source_vmid, $target_volname, $target_vmid) = @_; Can't the vmid arguments be dropped and extracted directly from the volid/volname instead? Would prevent potential mismatch for careless callers. > + > + my ($storeid) = parse_volume_id($source_volid); > + my (undef, $source_volname, undef, $base_name, $base_vmid, $isBase, $format) = parse_volname($cfg, $source_volid); > + > + activate_storage($cfg, $storeid); > + > + my $scfg = storage_config($cfg, $storeid); > + my $plugin = PVE::Storage::Plugin->lookup($scfg->{type}); > + Check that target_volname is valid (by parsing) either here or within each plugin's implementation? > + return $plugin->rename_volume($scfg, $storeid, $source_volname, $source_vmid, $target_volname, $target_vmid, $base_name, $base_vmid); Similar here, not all plugins need all of those parameters. Isn't taking $scfg, $storeid, $source_volid, $target_volname enough and let the plugin itself extract additional information if needed? > +} > + > # Various io-heavy operations require io/bandwidth limits which can be > # configured on multiple levels: The global defaults in datacenter.cfg, and > # per-storage overrides. When we want to do a restore from storage A to storage > diff --git a/PVE/Storage/LVMPlugin.pm b/PVE/Storage/LVMPlugin.pm > index df49b76..977e6a4 100644 > --- a/PVE/Storage/LVMPlugin.pm > +++ b/PVE/Storage/LVMPlugin.pm > @@ -339,6 +339,16 @@ sub lvcreate { > run_command($cmd, errmsg => "lvcreate '$vg/$name' error"); > } > > +sub lvrename { > + my ($vg, $oldname, $newname) = @_; > + > + my $cmd = ['/sbin/lvrename', $vg, $oldname, $newname]; > + run_command( > + ['/sbin/lvrename', $vg, $oldname, $newname], > + errmsg => "lvrename '${vg}/${oldname}' to '${newname}' error" > + ); > +} > + > sub alloc_image { > my ($class, $storeid, $scfg, $vmid, $fmt, $name, $size) = @_; > > @@ -584,6 +594,7 @@ sub volume_has_feature { > > my $features = { > copy => { base => 1, current => 1}, > + rename => {current => 1}, > }; > > my ($vtype, $name, $vmid, $basename, $basevmid, $isBase) = > @@ -684,4 +695,11 @@ sub volume_import_write { > input => '<&'.fileno($input_fh)); > } > > +sub rename_volume { > + my ($class, $scfg, $storeid, $source_volname, $source_vmid, $target_volname, $target_vmid, $base_name, $base_vmid) = @_; > + > + lvrename($scfg->{vgname}, $source_volname, $target_volname); > + return "${storeid}:${target_volname}"; > +} > + > 1; > diff --git a/PVE/Storage/LvmThinPlugin.pm b/PVE/Storage/LvmThinPlugin.pm > index c9e127c..45ad0ad 100644 > --- a/PVE/Storage/LvmThinPlugin.pm > +++ b/PVE/Storage/LvmThinPlugin.pm > @@ -355,6 +355,7 @@ sub volume_has_feature { > template => { current => 1}, > copy => { base => 1, current => 1, snap => 1}, > sparseinit => { base => 1, current => 1}, > + rename => {current => 1}, > }; > > my ($vtype, $name, $vmid, $basename, $basevmid, $isBase) = > diff --git a/PVE/Storage/Plugin.pm b/PVE/Storage/Plugin.pm > index 4a10a1f..4e6e288 100644 > --- a/PVE/Storage/Plugin.pm > +++ b/PVE/Storage/Plugin.pm > @@ -939,6 +939,7 @@ sub volume_has_feature { > snap => {qcow2 => 1} }, > sparseinit => { base => {qcow2 => 1, raw => 1, vmdk => 1}, > current => {qcow2 => 1, raw => 1, vmdk => 1} }, > + rename => { current =>{qcow2 => 1, raw => 1, vmdk => 1} }, > }; > > # clone_image creates a qcow2 volume > @@ -946,6 +947,10 @@ sub volume_has_feature { > defined($opts->{valid_target_formats}) && > !(grep { $_ eq 'qcow2' } @{$opts->{valid_target_formats}}); > > + return 0 if $feature eq 'rename' > + && $class->can('api') > + && $class->api() < 9; Style-nit: multiline post-if > + > my ($vtype, $name, $vmid, $basename, $basevmid, $isBase, $format) = > $class->parse_volname($volname); > > @@ -1463,4 +1468,28 @@ sub volume_import_formats { > return (); > } > > +sub rename_volume { > + my ($class, $scfg, $storeid, $source_volname, $source_vmid, $target_volname, $target_vmid, $base_name, $base_vmid) = @_; > + die "not implemented in storage plugin '$class'\n" if $class->can('api') && $class->api() < 9; > + > + my $basedir = $class->get_subdir($scfg, 'images'); > + my $sourcedir = "${basedir}/${source_vmid}"; > + my $targetdir = "${basedir}/${target_vmid}"; > + > + mkpath $targetdir; > + > + my (undef, $format, undef) = parse_name_dir($source_volname); > + $target_volname = "${target_volname}.${format}"; Ideally, the $target_volname already contains the format suffix at this point. Otherwise, passing a $target_volname with a format suffix results in a second suffix. > + > + my $old_path = "${sourcedir}/${source_volname}"; > + my $new_path = "${targetdir}/${target_volname}"; > + > + my $base = $base_name ? "${base_vmid}/${base_name}/" : ''; > + > + rename($old_path, $new_path) || > + die "rename '$old_path' to '$new_path' failed - $!\n"; > + > + return "${storeid}:${base}${target_vmid}/${target_volname}"; > +} > + > 1; > diff --git a/PVE/Storage/RBDPlugin.pm b/PVE/Storage/RBDPlugin.pm > index a8d1243..6e9bf8f 100644 > --- a/PVE/Storage/RBDPlugin.pm > +++ b/PVE/Storage/RBDPlugin.pm > @@ -728,6 +728,7 @@ sub volume_has_feature { > template => { current => 1}, > copy => { base => 1, current => 1, snap => 1}, > sparseinit => { base => 1, current => 1}, > + rename => {current => 1}, > }; > > my ($vtype, $name, $vmid, $basename, $basevmid, $isBase) = $class->parse_volname($volname); > @@ -743,4 +744,19 @@ sub volume_has_feature { > return undef; > } > > +sub rename_volume { > + my ($class, $scfg, $storeid, $source_volname, $source_vmid, $target_volname, $target_vmid, $base_name, $base_vmid) = @_; > + > + my $cmd = $rbd_cmd->($scfg, $storeid, 'rename', $source_volname, $target_volname); > + > + run_rbd_command( > + $cmd, > + errmsg => "could not rename image '${source_volname}' to '${target_volname}'", > + ); > + > + $base_name = $base_name ? "${base_name}/" : ''; > + > + return "${storeid}:${base_name}${target_volname}"; > +} > + > 1; > diff --git a/PVE/Storage/ZFSPoolPlugin.pm b/PVE/Storage/ZFSPoolPlugin.pm > index 2e2abe3..f04f443 100644 > --- a/PVE/Storage/ZFSPoolPlugin.pm > +++ b/PVE/Storage/ZFSPoolPlugin.pm > @@ -687,6 +687,7 @@ sub volume_has_feature { > copy => { base => 1, current => 1}, > sparseinit => { base => 1, current => 1}, > replicate => { base => 1, current => 1}, > + rename => {current => 1}, > }; > > my ($vtype, $name, $vmid, $basename, $basevmid, $isBase) = > @@ -789,4 +790,15 @@ sub volume_import_formats { > return $class->volume_export_formats($scfg, $storeid, $volname, undef, $base_snapshot, $with_snapshots); > } > > +sub rename_volume { > + my ($class, $scfg, $storeid, $source_volname, $source_vmid, $target_volname, $target_vmid, $base_name, $base_vmid) = @_; > + > + my $pool = $scfg->{pool}; > + $class->zfs_request($scfg, 5, 'rename', "${pool}/$source_volname", "${pool}/$target_volname"); > + > + $base_name = $base_name ? "${base_name}/" : ''; > + > + return "${storeid}:${base_name}${target_volname}"; > +} > + > 1; >