From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from firstgate.proxmox.com (firstgate.proxmox.com [212.224.123.68]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits)) (No client certificate requested) by lists.proxmox.com (Postfix) with ESMTPS id 4F2A9712F5 for ; Wed, 7 Apr 2021 16:22:51 +0200 (CEST) Received: from firstgate.proxmox.com (localhost [127.0.0.1]) by firstgate.proxmox.com (Proxmox) with ESMTP id 3AE7B117BB for ; Wed, 7 Apr 2021 16:22:21 +0200 (CEST) Received: from proxmox-new.maurer-it.com (proxmox-new.maurer-it.com [212.186.127.180]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits)) (No client certificate requested) by firstgate.proxmox.com (Proxmox) with ESMTPS id 2B637117A2 for ; Wed, 7 Apr 2021 16:22:20 +0200 (CEST) Received: from proxmox-new.maurer-it.com (localhost.localdomain [127.0.0.1]) by proxmox-new.maurer-it.com (Proxmox) with ESMTP id E98F043D7D for ; Wed, 7 Apr 2021 16:22:19 +0200 (CEST) From: Aaron Lauterer To: pve-devel@lists.proxmox.com Date: Wed, 7 Apr 2021 16:22:16 +0200 Message-Id: <20210407142218.29156-2-a.lauterer@proxmox.com> X-Mailer: git-send-email 2.20.1 In-Reply-To: <20210407142218.29156-1-a.lauterer@proxmox.com> References: <20210407142218.29156-1-a.lauterer@proxmox.com> MIME-Version: 1.0 Content-Transfer-Encoding: 8bit X-SPAM-LEVEL: Spam detection results: 0 AWL -0.016 Adjusted score from AWL reputation of From: address KAM_DMARC_STATUS 0.01 Test Rule for DKIM or SPF Failure with Strict Alignment RCVD_IN_DNSWL_MED -2.3 Sender listed at https://www.dnswl.org/, medium trust SPF_HELO_NONE 0.001 SPF: HELO does not publish an SPF Record SPF_PASS -0.001 SPF: sender matches SPF record URIBL_BLOCKED 0.001 ADMINISTRATOR NOTICE: The query to URIBL was blocked. See http://wiki.apache.org/spamassassin/DnsBlocklists#dnsbl-block for more information. [rbdplugin.pm] Subject: [pve-devel] [PATCH v2 storage 1/3] rbd: centralize rbd path concatenation X-BeenThere: pve-devel@lists.proxmox.com X-Mailman-Version: 2.1.29 Precedence: list List-Id: Proxmox VE development discussion List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Wed, 07 Apr 2021 14:22:51 -0000 The / paths are needed in quite a lot of places. Having one single place where they are created helps to reduce duplicate code and makes it easier to introduce new features. The 'add_pool_to_disk' sub was already doing that but the name was not really fitting. This commit renames it to the more general 'get_rbd_path' and changes the second parameter to the more widely used $volume instead of $disk. Furthermore, all occurences where "$pool/$volume" has been concatenated have been replaced with a call to get_rbd_path. Plus some minor code style cleanups for long function calls that were touched. Signed-off-by: Aaron Lauterer --- PVE/Storage/RBDPlugin.pm | 46 +++++++++++++++++++++++----------------- 1 file changed, 27 insertions(+), 19 deletions(-) diff --git a/PVE/Storage/RBDPlugin.pm b/PVE/Storage/RBDPlugin.pm index fab6d57..421539f 100644 --- a/PVE/Storage/RBDPlugin.pm +++ b/PVE/Storage/RBDPlugin.pm @@ -22,12 +22,10 @@ my $get_parent_image_name = sub { return $parent->{image} . "@" . $parent->{snapshot}; }; -my $add_pool_to_disk = sub { - my ($scfg, $disk) = @_; - +my $get_rbd_path = sub { + my ($scfg, $volume) = @_; my $pool = $scfg->{pool} ? $scfg->{pool} : 'rbd'; - - return "$pool/$disk"; + return "${pool}/${volume}"; }; my $build_cmd = sub { @@ -348,10 +346,10 @@ sub path { my ($vtype, $name, $vmid) = $class->parse_volname($volname); $name .= '@'.$snapname if $snapname; - my $pool = $scfg->{pool} ? $scfg->{pool} : 'rbd'; - return ("/dev/rbd/$pool/$name", $vmid, $vtype) if $scfg->{krbd}; + my $rbd_path = &$get_rbd_path($scfg, $name); + return ("/dev/rbd/${rbd_path}", $vmid, $vtype) if $scfg->{krbd}; - my $path = "rbd:$pool/$name"; + my $path = "rbd:${rbd_path}"; $path .= ":conf=$cmd_option->{ceph_conf}" if $cmd_option->{ceph_conf}; if (defined($scfg->{monhost})) { @@ -412,7 +410,13 @@ sub create_base { my $newvolname = $basename ? "$basename/$newname" : "$newname"; - my $cmd = &$rbd_cmd($scfg, $storeid, 'rename', &$add_pool_to_disk($scfg, $name), &$add_pool_to_disk($scfg, $newname)); + my $cmd = &$rbd_cmd( + $scfg, + $storeid, + 'rename', + &$get_rbd_path($scfg, $name), + &$get_rbd_path($scfg, $newname), + ); run_rbd_command($cmd, errmsg => "rbd rename '$name' error"); my $running = undef; #fixme : is create_base always offline ? @@ -458,8 +462,15 @@ sub clone_image { my $newvol = "$basename/$name"; $newvol = $name if length($snapname); - my $cmd = &$rbd_cmd($scfg, $storeid, 'clone', &$add_pool_to_disk($scfg, $basename), - '--snap', $snap, &$add_pool_to_disk($scfg, $name)); + my $cmd = &$rbd_cmd( + $scfg, + $storeid, + 'clone', + &$get_rbd_path($scfg, $basename), + '--snap', + $snap, + &$get_rbd_path($scfg, $name), + ); run_rbd_command($cmd, errmsg => "rbd clone '$basename' error"); @@ -575,9 +586,10 @@ sub deactivate_storage { } my $get_kernel_device_name = sub { - my ($pool, $name) = @_; + my ($scfg, $name) = @_; - return "/dev/rbd/$pool/$name"; + my $rbd_path = &$get_rbd_path($scfg, $name); + return "/dev/rbd/${rbd_path}"; }; sub map_volume { @@ -588,9 +600,7 @@ sub map_volume { my $name = $img_name; $name .= '@'.$snapname if $snapname; - my $pool = $scfg->{pool} ? $scfg->{pool} : 'rbd'; - - my $kerneldev = $get_kernel_device_name->($pool, $name); + my $kerneldev = $get_kernel_device_name->($scfg, $name); return $kerneldev if -b $kerneldev; # already mapped @@ -609,9 +619,7 @@ sub unmap_volume { my ($vtype, $name, $vmid) = $class->parse_volname($volname); $name .= '@'.$snapname if $snapname; - my $pool = $scfg->{pool} ? $scfg->{pool} : 'rbd'; - - my $kerneldev = $get_kernel_device_name->($pool, $name); + my $kerneldev = $get_kernel_device_name->($scfg, $name); if (-b $kerneldev) { my $cmd = &$rbd_cmd($scfg, $storeid, 'unmap', $kerneldev); -- 2.20.1