From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from firstgate.proxmox.com (firstgate.proxmox.com [212.224.123.68]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits)) (No client certificate requested) by lists.proxmox.com (Postfix) with ESMTPS id BB0D070371 for ; Fri, 2 Apr 2021 12:19:26 +0200 (CEST) Received: from firstgate.proxmox.com (localhost [127.0.0.1]) by firstgate.proxmox.com (Proxmox) with ESMTP id A0C92DB1C for ; Fri, 2 Apr 2021 12:19:26 +0200 (CEST) Received: from proxmox-new.maurer-it.com (proxmox-new.maurer-it.com [212.186.127.180]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits)) (No client certificate requested) by firstgate.proxmox.com (Proxmox) with ESMTPS id 49BEDDAF8 for ; Fri, 2 Apr 2021 12:19:25 +0200 (CEST) Received: from proxmox-new.maurer-it.com (localhost.localdomain [127.0.0.1]) by proxmox-new.maurer-it.com (Proxmox) with ESMTP id 117884596D for ; Fri, 2 Apr 2021 12:19:25 +0200 (CEST) From: Aaron Lauterer To: pve-devel@lists.proxmox.com Date: Fri, 2 Apr 2021 12:19:18 +0200 Message-Id: <20210402101923.13050-1-a.lauterer@proxmox.com> X-Mailer: git-send-email 2.20.1 MIME-Version: 1.0 Content-Transfer-Encoding: 8bit X-SPAM-LEVEL: Spam detection results: 0 AWL -0.016 Adjusted score from AWL reputation of From: address KAM_DMARC_STATUS 0.01 Test Rule for DKIM or SPF Failure with Strict Alignment RCVD_IN_DNSWL_MED -2.3 Sender listed at https://www.dnswl.org/, medium trust SPF_HELO_NONE 0.001 SPF: HELO does not publish an SPF Record SPF_PASS -0.001 SPF: sender matches SPF record URIBL_BLOCKED 0.001 ADMINISTRATOR NOTICE: The query to URIBL was blocked. See http://wiki.apache.org/spamassassin/DnsBlocklists#dnsbl-block for more information. [lvmplugin.pm, replication.pm, plugin.pm, glusterfsplugin.pm, drive.pm, zfspoolplugin.pm, dirplugin.pm, cifsplugin.pm, rbdplugin.pm, storage.pm, nfsplugin.pm, qemu.pm, qm.pm, proxmox.com, lvmthinplugin.pm] Subject: [pve-devel] [PATCH v6 series 0/5] disk reassign: add new feature X-BeenThere: pve-devel@lists.proxmox.com X-Mailman-Version: 2.1.29 Precedence: list List-Id: Proxmox VE development discussion List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Fri, 02 Apr 2021 10:19:26 -0000 This series implements a new feature which allows users to easily reassign disks between VMs. Currently this is only possible with one of the following manual steps: * rename the disk image/file and do a `qm rescan` * configure the disk manually and use the old image name, having an image for VM A assigned to VM B The latter can cause unexpected behavior because PVE expects that the VMID in a disk name always corresponds to the VM it is assigned to. Thus when a disk, original from VM A was manually configured as disk for VM B it happens that, when deleting VM A, the disk in question will be deleted as well because it still had the VMID of VM A in it's name. To issue a reassign from the CLI run: qm reassign_disk where is the config key of the disk, e.g. ide0, scsi1 and so on. The following storage types are implemented at the moment: * dir based ones * directory * NFS * CIFS * gluster * ZFS * (thin) LVM * Ceph RBD v5 -> v6: * guard Replication snapshot cleanup * add permission check for target vmid * changed regex to match unused keys better * refactor dir based feature check to reduce code repetition v4 -> v5: * rebase on current master * reorder patches * rename `drive_key` to `drive_name` thanks @Dominic for pointing out that there already are a lot of different names in use for this [0] and not to invent another one ;) * implemented suggested changes from Fabian [1][2]. More directly in the patches themselves v3 -> v4: * revert intermediate storage plugin for directory based plugins * add a `die "not supported"` method in Plugin.pm * dir based plugins now call the file_reassign_volume method in Plugin.pm as the generic file/directory based method * restored old `volume_has_feature` method in Plugin.pm and override it in directory based plugins to check against the new `reassign` feature (not too happy about the repetition for each plugin) * task description mapping has been moved from widget-toolkit to pve-manager/utils v2 -> v3: * change locking approach * add more checks * add intermedia storage plugin for directory based plugins * use feature flags * split up the reassign method to have a dedicated method for the renaming itself * handle linked clones * clean up if disk used to be replicated I hope I didn't forget anything major. v1 -> v2: print info about the new disk volid and key at the end of the job so it shows up in the CLI output and task log Changes from RFC -> V1: * support to reassign unused disks * digest for target vm config * reorder the checks a bit * adding another one to check if the given key for the disk even exists in the config. [0] https://lists.proxmox.com/pipermail/pve-devel/2020-November/045986.html [1] https://lists.proxmox.com/pipermail/pve-devel/2020-November/046031.html [2] https://lists.proxmox.com/pipermail/pve-devel/2020-November/046030.html storage: Aaron Lauterer (1): add disk reassign feature PVE/Storage.pm | 15 +++++++-- PVE/Storage/CIFSPlugin.pm | 13 ++++++++ PVE/Storage/DirPlugin.pm | 13 ++++++++ PVE/Storage/GlusterfsPlugin.pm | 13 ++++++++ PVE/Storage/LVMPlugin.pm | 24 ++++++++++++++ PVE/Storage/LvmThinPlugin.pm | 1 + PVE/Storage/NFSPlugin.pm | 13 ++++++++ PVE/Storage/Plugin.pm | 60 ++++++++++++++++++++++++++++++++++ PVE/Storage/RBDPlugin.pm | 31 ++++++++++++++++++ PVE/Storage/ZFSPoolPlugin.pm | 26 +++++++++++++++ 10 files changed, 207 insertions(+), 2 deletions(-) qemu-server: Aaron Lauterer (2): disk reassign: add API endpoint cli: disk reassign: add reassign_disk to qm command PVE/API2/Qemu.pm | 172 ++++++++++++++++++++++++++++++++++++++++ PVE/CLI/qm.pm | 2 + PVE/QemuServer/Drive.pm | 4 + 3 files changed, 178 insertions(+) guest-common: Aaron Lauterer (1): Replication: mention disk reassign in comment of possible reasons PVE/Replication.pm | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) manager: Aaron Lauterer (1): ui: tasks: add qmreassign task description www/manager6/Utils.js | 1 + 1 file changed, 1 insertion(+) -- 2.20.1