From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from gate001.proxmox.com (gate001.proxmox.com [IPv6:2a0f:8001:1:32::40]) by lore.proxmox.com (Postfix) with ESMTPS id 0106E1FF0AA for ; Tue, 06 Oct 2026 14:44:14 +0200 (CEST) Received: from gate001.proxmox.com (localhost.localdomain [127.0.0.1]) by gate001.proxmox.com (Proxmox) with ESMTP id 45D3521376; Tue, 06 Oct 2026 14:44:12 +0200 (CEST) From: Fiona Ebner To: pve-devel@lists.proxmox.com, Michal Fox Subject: applied: [PATCH manager] fix #4986: jobs: do not get stuck if the task log is missing Date: Tue, 6 Oct 2026 14:41:29 +0200 Message-ID: <179129048526.513195.3926366735136520416.b4-ty@proxmox.com> X-Mailer: git-send-email 2.47.3 In-Reply-To: <20261003153820.7-1-me@dualfroz.com> References: <20261003153820.7-1-me@dualfroz.com> MIME-Version: 1.0 Content-Type: text/plain; charset="utf-8" Content-Transfer-Encoding: 8bit X-Bm-Milter-Handled: 55990f41-d878-4baa-be0a-ee34c49e34d2 X-Bm-Transport-Timestamp: 1791290647387 X-SPAM-LEVEL: Spam detection results: 0 AWL 0.457 Adjusted score from AWL reputation of From: address DMARC_MISSING 0.1 Missing DMARC policy KAM_DMARC_STATUS 0.01 Test Rule for DKIM or SPF Failure with Strict Alignment (newer systems) RCVD_IN_DNSWL_MED -2.3 Sender listed at https://www.dnswl.org/, medium trust SPF_HELO_NONE 0.001 SPF: HELO does not publish an SPF Record SPF_PASS -0.001 SPF: sender matches SPF record Message-ID-Hash: LI6JVFOUZIF76BYGIJRBPIQOTB5YVXTM X-Message-ID-Hash: LI6JVFOUZIF76BYGIJRBPIQOTB5YVXTM X-MailFrom: f.ebner@proxmox.com X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header X-Mailman-Version: 3.3.10 Precedence: list List-Id: Proxmox VE development discussion List-Help: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: On Sat, 03 Oct 2026 15:38:20 +0000, Michal Fox wrote: > When the scheduler checks whether the last run of a job has finished, > it dies if the task log of that run does not exist. The job is then > skipped with 'could not update job state, skipping - no such task' on > every iteration, so it never runs again until its state file is > cleaned up manually. > > The task log can be gone, for example after a crash. If the task is > not running anymore, treat it as stopped with an error status instead, > so that the job gets scheduled again, like Proxmox Backup Server does > since commit 48fbce07 ("fix #4895: scheduled jobs: ignore task-log not > found error"). > > [...] Applied, thanks! I switched to using PVE::File::file_exists() for the existence check and also made the scheduler issue an explicit warning. [1/1] fix #4986: jobs: do not get stuck if the task log is missing commit: ac0c87dd37115e3046cbfa5756f2a02fc659e8cd