From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from firstgate.proxmox.com (firstgate.proxmox.com [212.224.123.68]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits)) (No client certificate requested) by lists.proxmox.com (Postfix) with ESMTPS id 7FA6764619 for ; Thu, 3 Mar 2022 13:52:05 +0100 (CET) Received: from firstgate.proxmox.com (localhost [127.0.0.1]) by firstgate.proxmox.com (Proxmox) with ESMTP id 763BC32260 for ; Thu, 3 Mar 2022 13:52:05 +0100 (CET) Received: from proxmox-new.maurer-it.com (proxmox-new.maurer-it.com [94.136.29.106]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits)) (No client certificate requested) by firstgate.proxmox.com (Proxmox) with ESMTPS id E586432257 for ; Thu, 3 Mar 2022 13:52:04 +0100 (CET) Received: from proxmox-new.maurer-it.com (localhost.localdomain [127.0.0.1]) by proxmox-new.maurer-it.com (Proxmox) with ESMTP id B4A4941CD6 for ; Thu, 3 Mar 2022 13:52:04 +0100 (CET) Date: Thu, 3 Mar 2022 13:52:03 +0100 From: Wolfgang Bumiller To: Dominik Csapak Cc: pbs-devel@lists.proxmox.com Message-ID: <20220303125203.vv5mfand3k7ykwxm@olga.proxmox.com> References: <20220303115337.3040977-1-d.csapak@proxmox.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20220303115337.3040977-1-d.csapak@proxmox.com> X-SPAM-LEVEL: Spam detection results: 0 AWL 0.375 Adjusted score from AWL reputation of From: address BAYES_00 -1.9 Bayes spam probability is 0 to 1% KAM_DMARC_STATUS 0.01 Test Rule for DKIM or SPF Failure with Strict Alignment SPF_HELO_NONE 0.001 SPF: HELO does not publish an SPF Record SPF_PASS -0.001 SPF: sender matches SPF record T_SCC_BODY_TEXT_LINE -0.01 - URIBL_BLOCKED 0.001 ADMINISTRATOR NOTICE: The query to URIBL was blocked. See http://wiki.apache.org/spamassassin/DnsBlocklists#dnsbl-block for more information. [schema.rs] Subject: Re: [pbs-devel] [PATCH proxmox] proxmox-schema: add convenience macros for ParameterError X-BeenThere: pbs-devel@lists.proxmox.com X-Mailman-Version: 2.1.29 Precedence: list List-Id: Proxmox Backup Server development discussion List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Thu, 03 Mar 2022 12:52:05 -0000 On Thu, Mar 03, 2022 at 12:53:37PM +0100, Dominik Csapak wrote: > Signed-off-by: Dominik Csapak > --- > proxmox-schema/src/schema.rs | 20 +++++++++++++++++++- > 1 file changed, 19 insertions(+), 1 deletion(-) > > diff --git a/proxmox-schema/src/schema.rs b/proxmox-schema/src/schema.rs > index 58c6a82..c568580 100644 > --- a/proxmox-schema/src/schema.rs > +++ b/proxmox-schema/src/schema.rs > @@ -21,6 +21,24 @@ pub struct ParameterError { > error_list: Vec<(String, Error)>, > } > > +/// Like anyhow's `format_err` but producing a `ParameterError`. > +#[macro_export] > +macro_rules! format_param_err { this makes: - `bail` and `format_err`, - `io_bail`, `io_format_err`, where `io_` is the common prefix - `param_bail`, `format_param_err`, where `param_` is in two different places ;-) please rename this to `param_format_err` for consistency > + ($field:expr, $($msg:tt)+) => { > + $crate::ParameterError::from(($field, format_err!($($msg)+))) > + }; > +} > + > +/// Like anyhow's `bail` but enclosing a `ParameterError`, so > +/// a `downcast` can extract it later. This is useful for > +/// API calls that need to do parameter checking manually. > +#[macro_export] > +macro_rules! param_bail { > + ($field:expr, $($msg:tt)+) => {{ > + return Err($crate::format_param_err!($field, $($msg)+).into()); > + }}; > +} > + > impl std::error::Error for ParameterError {} > > impl ParameterError { > @@ -530,7 +548,7 @@ impl ArraySchema { > for (i, item) in list.iter().enumerate() { > let result = self.items.verify_json(item); > if let Err(err) = result { > - return Err(ParameterError::from((format!("[{}]", i), err)).into()); > + param_bail!(format!("[{}]", i), err); I don't really like the fact that the `err` which is already an `anyhow::Error` is now wrapped in an extra `format_err!()` call. I think this instance should probably not be changed to `param_bail!`.