From: Daniel Kral <d.kral@proxmox.com>
To: pve-devel@lists.proxmox.com
Subject: [PATCH qemu-server 3/7] api: qemu: improve wording in timeout parameter descriptions
Date: Wed, 22 Jul 2026 16:01:45 +0200 [thread overview]
Message-ID: <20260722140149.296952-4-d.kral@proxmox.com> (raw)
In-Reply-To: <20260722140149.296952-1-d.kral@proxmox.com>
Signed-off-by: Daniel Kral <d.kral@proxmox.com>
---
src/PVE/API2/Qemu.pm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/src/PVE/API2/Qemu.pm b/src/PVE/API2/Qemu.pm
index 28cbb9b0..bf6ade58 100644
--- a/src/PVE/API2/Qemu.pm
+++ b/src/PVE/API2/Qemu.pm
@@ -3505,7 +3505,7 @@ __PACKAGE__->register_method({
},
targetstorage => get_standard_option('pve-targetstorage'),
timeout => {
- description => "Wait maximal timeout seconds.",
+ description => "Maximum timeout in seconds.",
type => 'integer',
minimum => 0,
default => 'max(30, vm memory in GiB)',
@@ -3681,7 +3681,7 @@ __PACKAGE__->register_method({
skiplock => get_standard_option('skiplock'),
migratedfrom => get_standard_option('pve-node', { optional => 1 }),
timeout => {
- description => "Wait maximal timeout seconds.",
+ description => "Maximum timeout in seconds.",
type => 'integer',
minimum => 0,
optional => 1,
@@ -3856,7 +3856,7 @@ __PACKAGE__->register_method({
),
skiplock => get_standard_option('skiplock'),
timeout => {
- description => "Wait maximal timeout seconds.",
+ description => "Maximum timeout in seconds.",
type => 'integer',
minimum => 0,
optional => 1,
@@ -3970,7 +3970,7 @@ __PACKAGE__->register_method({
{ completion => \&PVE::QemuServer::complete_vmid_running },
),
timeout => {
- description => "Wait maximal timeout seconds for the shutdown.",
+ description => "Maximum timeout in seconds for the shutdown.",
type => 'integer',
minimum => 0,
optional => 1,
--
2.47.3
next prev parent reply other threads:[~2026-07-22 14:03 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-22 14:01 [PATCH-SERIES ha-manager/qemu-server 0/7] fix #7230: acknowledge configured shutdown timeout for HA resources Daniel Kral
2026-07-22 14:01 ` [PATCH qemu-server 1/7] rename config_aware_timeout to config_aware_start_timeout Daniel Kral
2026-07-22 14:01 ` [PATCH qemu-server 2/7] vm_stop: introduce config_aware_shutdown_timeout helper Daniel Kral
2026-07-22 14:01 ` Daniel Kral [this message]
2026-07-22 14:01 ` [PATCH qemu-server 4/7] api: qemu: add verbose description for shutdown and reboot timeouts Daniel Kral
2026-07-22 14:01 ` [PATCH qemu-server 5/7] fix #7230: api: vm_shutdown: make HA resources acknowledge config timeout Daniel Kral
2026-07-22 14:01 ` [PATCH qemu-server 6/7] api: vm_reboot: initialize the config-aware timeout in API handler Daniel Kral
2026-07-22 14:01 ` [PATCH ha-manager 7/7] fix #7230: resources: let shutdown api handle timeout fallback value Daniel Kral
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260722140149.296952-4-d.kral@proxmox.com \
--to=d.kral@proxmox.com \
--cc=pve-devel@lists.proxmox.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.