From: Daniel Kral <d.kral@proxmox.com>
To: pve-devel@lists.proxmox.com
Subject: [PATCH ha-manager 12/16] lrm: rename update_service_status to update_lrm_status
Date: Mon, 20 Jul 2026 14:37:01 +0200 [thread overview]
Message-ID: <20260720123705.216089-13-d.kral@proxmox.com> (raw)
In-Reply-To: <20260720123705.216089-1-d.kral@proxmox.com>
update_lrm_status() is more fitting than update_service_status() here as
the internal LRM state that is updated by the information provided by
manager status does affect the whole LRM's behavior (node_status and
shutdown_request) and not only the LRM's behavior for its HA resources
(service_status).
Signed-off-by: Daniel Kral <d.kral@proxmox.com>
---
src/PVE/HA/LRM.pm | 21 ++++++++++++++++-----
1 file changed, 16 insertions(+), 5 deletions(-)
diff --git a/src/PVE/HA/LRM.pm b/src/PVE/HA/LRM.pm
index bdf55d6e..920fda52 100644
--- a/src/PVE/HA/LRM.pm
+++ b/src/PVE/HA/LRM.pm
@@ -210,7 +210,19 @@ sub flush_lrm_status {
return 1;
}
-sub update_service_status {
+=head3 $self->update_lrm_status()
+
+Updates the internal LRM status properties to reflect the state given by the
+C<L<manager_status|PVE::HA::Env::read_manager_status()>>.
+
+The internal LRM status properties that are updated are C<node_status>,
+C<service_status>, and C<shutdown_request>.
+
+Returns 1 if the update was successful, otherwise returns undef.
+
+=cut
+
+sub update_lrm_status {
my ($self) = @_;
my $haenv = $self->{haenv};
@@ -224,7 +236,6 @@ sub update_service_status {
my $nodename = $haenv->nodename();
$self->{node_status} = $ms->{node_status}->{$nodename} || 'unknown';
- # FIXME: method name is a bit confusing for doing this, either rename or move
if (!$self->{shutdown_request}) {
my $request = $ms->{node_request}->{$nodename} // {};
if ($request->{maintenance}) {
@@ -378,7 +389,7 @@ sub work {
my $status = $self->get_local_status();
my $state = $status->{state};
- $self->update_service_status();
+ $self->update_lrm_status();
my $fence_request = $self->is_fence_requested();
@@ -509,7 +520,7 @@ sub work {
# if we could not get the current service status there's no point
# in doing anything, try again next round.
- return if !$self->update_service_status();
+ return if !$self->update_lrm_status();
if ($self->{shutdown_request}) {
@@ -608,7 +619,7 @@ sub work {
} elsif ($state eq 'maintenance') {
my $startime = $haenv->get_time();
- return if !$self->update_service_status();
+ return if !$self->update_lrm_status();
# wait until all active services moved away
my $service_count = $self->active_service_count();
--
2.47.3
next prev parent reply other threads:[~2026-07-20 12:39 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-20 12:36 [PATCH-SERIES ha-manager 00/16] some sid parsing and LRM speedup improvements Daniel Kral
2026-07-20 12:36 ` [PATCH ha-manager 01/16] make tidy Daniel Kral
2026-07-20 12:36 ` [PATCH ha-manager 02/16] resources: remove commented ipaddr resource type Daniel Kral
2026-07-20 12:36 ` [PATCH ha-manager 03/16] tree-wide: use the term vmid instead of name when referring to VMs/CTs Daniel Kral
2026-07-20 12:36 ` [PATCH ha-manager 04/16] api: resources: remove unused return values at parse_sid callsites Daniel Kral
2026-07-20 12:36 ` [PATCH ha-manager 05/16] make parse_sid always return an array Daniel Kral
2026-07-20 12:36 ` [PATCH ha-manager 06/16] config: use early returns in parse_sid Daniel Kral
2026-07-20 12:36 ` [PATCH ha-manager 07/16] config: make update_single_resource_config_inplace only allow sids Daniel Kral
2026-07-20 12:36 ` [PATCH ha-manager 08/16] introduce separate parse_vmid_or_sid helper subroutine Daniel Kral
2026-07-20 12:36 ` [PATCH ha-manager 09/16] drop the unmodified sid return array entry value from parse_sid Daniel Kral
2026-07-20 12:36 ` [PATCH ha-manager 10/16] lrm: document and initialize LRM instance properties Daniel Kral
2026-07-20 12:37 ` [PATCH ha-manager 11/16] lrm: rename update_lrm_status to flush_lrm_status Daniel Kral
2026-07-20 12:37 ` Daniel Kral [this message]
2026-07-20 12:37 ` [PATCH ha-manager 13/16] lrm: update the service status once per work iteration Daniel Kral
2026-07-20 12:37 ` [PATCH ha-manager 14/16] lrm: read service config " Daniel Kral
2026-07-20 12:37 ` [PATCH ha-manager 15/16] lrm: compute valid service uids hash set " Daniel Kral
2026-07-20 12:37 ` [PATCH ha-manager 16/16] lrm: prune non-existent HA resources from results " Daniel Kral
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260720123705.216089-13-d.kral@proxmox.com \
--to=d.kral@proxmox.com \
--cc=pve-devel@lists.proxmox.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.